Close

Results 1 to 11 of 11
  1. #1
    Join Date
    Aug 2015
    Posts
    4
    Rep Points
    7.3
    Mentioned
    0 Post(s)
    Rep Power
    0


    2 out of 2 members liked this post. Yes Reputation No

    N54 MHD Extremely lean

    I am self-tuning my N54 using MHD. I've currently got VRSF cattless pipes, aFe DCI, and am running 17-18psi with a 50/50 mix of E85 and 91. Corrected 375whp and 470wtq at 5000ft altitude.

    The car runs extremely lean while in spool mode, in the 20:1 range, up until 2000 rpm (spool mode max is 2600rpm). My spool mode fuel table is richer than stock, 15.0 at the leanest and much richer than stock in the 90%+ load ranges (where it gets lean). I don't have a hardware fueling issue, I have confirmed with other data logging software that the commanded AFR is actually 20:1. There are no codes since the ECU wants to be this lean, its hitting targets just like it wants.

    It seems to ignore my spool mode fuel table. I've compared my bin to several others including the JB4 BEF and can't find any significant differences.

    Is there some table I've missed, or is my only option to disable spool mode? If I accelerate in a way to avoid spool mode, it does not go lean.

  2. #2
    Join Date
    Feb 2014
    Posts
    410
    Rep Points
    396.3
    Mentioned
    58 Post(s)
    Rep Power
    4


    Yes Reputation No
    Disabled the stock lean spool toggle?

  3. #3
    Join Date
    Feb 2014
    Posts
    410
    Rep Points
    396.3
    Mentioned
    58 Post(s)
    Rep Power
    4


    1 out of 1 members liked this post. Yes Reputation No
    Didn't read far enough that you're aware of it. Ambient pressure is registering as 12.5psi, is that accurate? That is really low, as is starting WOT at 1200rpm in what I can only assume is 2nd or 3rd gear. You're dragging on 70-100 load for a long time. Once it reaches ~1900-2000rpm / 120 load though, AFR comes up more normal.

    My car was never a fan of lean spool and I'd be somewhat leery keeping it enabled with E85 in the mix either way. Unless you really want it on for some reason, why not just disable it since you've tuned the fuel already?

  4. #4
    Join Date
    Mar 2014
    Posts
    736
    Rep Points
    1,056.7
    Mentioned
    27 Post(s)
    Rep Power
    11


    Yes Reputation No
    That's normal for spool mode. My theory on it is that with such extreme overlap, fresh air blows straight through the engine near TDC, helping to spool the turbo without surge, but the AFR as read by the O2 sensors reads much leaner than the actual mixture in the cylinders and the DME compensates for that.

  5. #5
    Join Date
    Nov 2012
    Posts
    2,391
    Rep Points
    3,122.5
    Mentioned
    178 Post(s)
    Rep Power
    32


    Yes Reputation No
    Click here to enlarge Originally Posted by Tiron Click here to enlarge
    I have confirmed with other data logging software that the commanded AFR is actually 20:1
    This param in INPA / other BMW software is incorrect, FYI Click here to enlarge
    BIG things coming soon Click here to enlarge

  6. #6
    Join Date
    Aug 2015
    Posts
    4
    Rep Points
    7.3
    Mentioned
    0 Post(s)
    Rep Power
    0



    Yes Reputation No
    Log uploaded to datazap:
    http://www.datazap.me/u/tiron/spool-...0&data=3-13-21

    Click here to enlarge Originally Posted by jyamona@motiv Click here to enlarge
    This param in INPA / other BMW software is incorrect, FYI
    I was using the SAE OBDII PID for commanded lambda, it looks correct to me.

    Click here to enlarge Originally Posted by RSL Click here to enlarge
    Didn't read far enough that you're aware of it. Ambient pressure is registering as 12.5psi, is that accurate? That is really low, as is starting WOT at 1200rpm in what I can only assume is 2nd or 3rd gear. You're dragging on 70-100 load for a long time.
    I am 5000ft elevation, 12.5 is accurate and spool sucks up here. I have not disabled spool mode because it drags on in the 80-90 load range even longer with it off. I like to get into boost before 3000rpm Click here to enlarge

    Click here to enlarge Originally Posted by bradsm87 Click here to enlarge
    That's normal for spool mode. My theory on it is that with such extreme overlap, fresh air blows straight through the engine near TDC, helping to spool the turbo without surge, but the AFR as read by the O2 sensors reads much leaner than the actual mixture in the cylinders and the DME compensates for that.
    That's an interesting thought, I've seen it happen on some cammed V8s I've tuned before, I guess I was expecting the requested lambda to match my fuel mode table in this case. I'll try running normal cam timing in spool mode and see if the AFRs change.
    Last edited by Tiron; 06-15-2017 at 11:14 AM.

  7. #7
    Join Date
    Nov 2012
    Posts
    2,391
    Rep Points
    3,122.5
    Mentioned
    178 Post(s)
    Rep Power
    32


    Yes Reputation No
    What do you have set in Toggles > Functions > Disable Lean Spool?

    This is different than "Spool Mode" (which uses the spool mode tables), and should be turned off, aka set to 00.
    BIG things coming soon Click here to enlarge

  8. #8
    Join Date
    Aug 2015
    Posts
    4
    Rep Points
    7.3
    Mentioned
    0 Post(s)
    Rep Power
    0



    Yes Reputation No
    Click here to enlarge Originally Posted by jyamona@motiv Click here to enlarge
    What do you have set in Toggles > Functions > Disable Lean Spool?
    This is different than "Spool Mode" (which uses the spool mode tables), and should be turned off, aka set to 00.
    I have the same value as my stock bin, which is 01 or "enabled". The way I read these names that means the toggle to turn off lean spool is set.

    I did not realize this wasn't a toggle for the entirety of spool mode though, I assumed it would turn off spool mode altogether.

  9. #9
    Join Date
    Nov 2012
    Posts
    2,391
    Rep Points
    3,122.5
    Mentioned
    178 Post(s)
    Rep Power
    32


    Yes Reputation No
    Click here to enlarge Originally Posted by Tiron Click here to enlarge
    I have the same value as my stock bin, which is 01 or "enabled". The way I read these names that means the toggle to turn off lean spool is set.

    I did not realize this wasn't a toggle for the entirety of spool mode though, I assumed it would turn off spool mode altogether.
    Nope, spool mode tables and spool mode will still work, but it should fix your 20:1 AFR issue!
    BIG things coming soon Click here to enlarge

  10. #10
    Join Date
    Feb 2014
    Posts
    410
    Rep Points
    396.3
    Mentioned
    58 Post(s)
    Rep Power
    4


    Yes Reputation No
    ^^ What he said, as usual Click here to enlarge I don't think there's any way to turn spool mode off (at least with anything currently defined). All you can really do is move the end RPM out of the way to avoid it if you don't want to use it for some reason. Spool mode = good, lean spool mode = bad (for me).

  11. #11
    Join Date
    Aug 2015
    Posts
    4
    Rep Points
    7.3
    Mentioned
    0 Post(s)
    Rep Power
    0



    1 out of 1 members liked this post. Yes Reputation No
    That seems to have fixed it. Disabling lean spool fixes the 20:1, and AFRs now closely match what I have in my spool mode fuel table. Thanks for the input guys!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •