Close

Results 1 to 15 of 15
  1. #1
    Join Date
    Nov 2010
    Posts
    3
    Rep Points
    0.3
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No

    At what torque level does the stock clutch start slipping?

    I know this is off topic, but at what torque does the stock clutch start slipping?

  2. #2
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,681
    Rep Points
    31,507.9
    Mentioned
    2062 Post(s)
    Rep Power
    316


    Reputation: Yes | No

  3. #3
    Join Date
    Apr 2010
    Posts
    4,608
    Rep Points
    3,236.6
    Mentioned
    24 Post(s)
    Rep Power
    33


    Reputation: Yes | No
    This is a good question. I have seen some dynos start slip at 450 wtq - 500 wtq or thereabouts. It also depends on how hot the clutch is during the pull and how many miles are on it etc...
    Some people live long, meaningful lives.

    Other people eat shit and die.

    I'm not racist, I hate everybody equally; especially fat people.


    Click here to enlarge

  4. #4
    Join Date
    Nov 2010
    Posts
    3
    Rep Points
    0.3
    Mentioned
    0 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Thanks for the reply, I had my car on a dyno yesterday and something started slipping, best run got to 440 tq at 4200 rpm. No clutch smell however, but the car does have 59k miles.

  5. #5
    Join Date
    Nov 2010
    Location
    Netherlands
    Posts
    6,215
    Rep Points
    6,741.7
    Mentioned
    73 Post(s)
    Rep Power
    68


    Reputation: Yes | No
    ON the same subject, what torque can you give an AT on a N54 before it breaks?
    There are two theories to arguing with women. Neither one works

  6. #6
    Join Date
    Apr 2010
    Posts
    4,608
    Rep Points
    3,236.6
    Mentioned
    24 Post(s)
    Rep Power
    33


    1 out of 1 members liked this post. Reputation: Yes | No
    Click here to enlarge Originally Posted by DavidV Click here to enlarge
    ON the same subject, what torque can you give an AT on a N54 before it breaks?
    Automatics can handle a lot of torque, to date I dont know of any complete catastrophic AT failures. I have seen a few videos lurking around of automatics downshifting when not supposed to etc... But nothing destructive, the ZF trans in this car is very very strong.
    Some people live long, meaningful lives.

    Other people eat shit and die.

    I'm not racist, I hate everybody equally; especially fat people.


    Click here to enlarge

  7. #7
    Join Date
    Nov 2010
    Location
    Netherlands
    Posts
    6,215
    Rep Points
    6,741.7
    Mentioned
    73 Post(s)
    Rep Power
    68


    Reputation: Yes | No
    Click here to enlarge Originally Posted by DBFIU Click here to enlarge
    Automatics can handle a lot of torque, to date I dont know of any complete catastrophic AT failures. I have seen a few videos lurking around of automatics downshifting when not supposed to etc... But nothing destructive, the ZF trans in this car is very very strong.
    Thank you Click here to enlarge
    There are two theories to arguing with women. Neither one works

  8. #8
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,681
    Rep Points
    31,507.9
    Mentioned
    2062 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by DavidV Click here to enlarge
    ON the same subject, what torque can you give an AT on a N54 before it breaks?
    Once you get to 500 wheel torque you are really pushing your luck.

  9. #9
    Join Date
    Apr 2010
    Posts
    4,608
    Rep Points
    3,236.6
    Mentioned
    24 Post(s)
    Rep Power
    33


    Reputation: Yes | No
    If I remember correctly all the sub 11.5 seconds cars are autos making above 480 wtq. Larry launches off the line with nitrous too.
    Some people live long, meaningful lives.

    Other people eat shit and die.

    I'm not racist, I hate everybody equally; especially fat people.


    Click here to enlarge

  10. #10
    Join Date
    Jul 2010
    Location
    Louisiana
    Posts
    1,744
    Rep Points
    1,330.4
    Mentioned
    14 Post(s)
    Rep Power
    14


    Reputation: Yes | No
    So I have full bolt ons last night, and during a launch it felt like it was slipping or not catching from 1st to 2nd. I let off very quickly, when I tried later there was no problem. Am I over paranoid or what? It could have been nothing, but I just thought I would ask.

    P.S it felt like it went like 200 rpm over the rev limiter when I let off.
    Click here to enlarge


  11. #11
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,681
    Rep Points
    31,507.9
    Mentioned
    2062 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by DBFIU Click here to enlarge
    If I remember correctly all the sub 11.5 seconds cars are autos making above 480 wtq. Larry launches off the line with nitrous too.
    Yep, that's reaching the upper end though.

  12. #12
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,681
    Rep Points
    31,507.9
    Mentioned
    2062 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Gbreee90 Click here to enlarge
    So I have full bolt ons last night, and during a launch it felt like it was slipping or not catching from 1st to 2nd. I let off very quickly, when I tried later there was no problem. Am I over paranoid or what? It could have been nothing, but I just thought I would ask.

    P.S it felt like it went like 200 rpm over the rev limiter when I let off.
    If its fine right now I would say just paranoid and you should slip it a bit during launch. Was it cold and did you launch before? If not, once the clutch was heated did it grip?

  13. #13
    Join Date
    Jul 2010
    Location
    Louisiana
    Posts
    1,744
    Rep Points
    1,330.4
    Mentioned
    14 Post(s)
    Rep Power
    14


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Sticky Click here to enlarge
    If its fine right now I would say just paranoid and you should slip it a bit during launch. Was it cold and did you launch before? If not, once the clutch was heated did it grip?
    No, it wasn't cold, and its AT. Everything SEEMS to be fine, not really sure how I can ever know though.
    Click here to enlarge


  14. #14
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,681
    Rep Points
    31,507.9
    Mentioned
    2062 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Gbreee90 Click here to enlarge
    No, it wasn't cold, and its AT. Everything SEEMS to be fine, not really sure how I can ever know though.
    Oh, and here I thought you were talking about a manual.

  15. #15
    Join Date
    Jul 2010
    Location
    Louisiana
    Posts
    1,744
    Rep Points
    1,330.4
    Mentioned
    14 Post(s)
    Rep Power
    14


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Sticky Click here to enlarge
    Oh, and here I thought you were talking about a manual.
    I wish Click here to enlarge
    Click here to enlarge


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •