Close

Page 1 of 2 12 LastLast
Results 1 to 25 of 29
  1. #1
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7


    Reputation: Yes | No

    Exclamation Started car, engine malfunction, smoke... help

    Someone please calm my nerves... I drove my car yesterday, no issues at all. Last night we got a ton of rain, they had predicted 2+ inches. I just I went out and started it... engine malfunction, reduced power. Seems like a good amount of white smoke out of both exhausts. I'm not sure if it is actually smoke or a ton of condensation at this point. It's incredibly moist (giggity) out, foggy as hell etc...

    opened my hood and it's very damp/wet in there. Checked for codes, it's showing these:

    P2AB4
    P2EE6
    P2ABD

    thoughts!?
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  2. #2
    Join Date
    Feb 2013
    Location
    Maryland
    Posts
    1,554
    Rep Points
    2,516.8
    Mentioned
    67 Post(s)
    Rep Power
    26


    Reputation: Yes | No
    Sounds like condensation....Did the car drink any water to your knowledge? Drive through anything gnarly?

    I saw someone hydrolock their Taurus yesterday, drove right through a river disguised as a puddle. Plumes of thick white smoke, I could hear the knock from my lane with the windows up.
    E88 N54 Alpinweiss/Coral Red/Motiv HTA 3586r Tial .82AR/Motiv Port Fuel/BMR 3.5" Exhaust/ER CP/Synapse/VRSF FMIC/Rob Beck PCV Valve + Cap/ST Coilovers/M3 FCA + Tension Rods/M3 Subframe Bushings/M3 FSB/AA Strutbrace/DINAN Camber Plates/Apex ARC-8/Project Kics/VAC Hubs/Rogue Transmission Mounts/Alpina TCU Flash/Icarbon/Kerscher/BMW Performance
    F30 335 X-Drive EBII....PPK otherwise Stock
    Click here to enlarge

  3. #3
    Join Date
    Feb 2012
    Location
    Naples, FL
    Posts
    2,085
    Rep Points
    2,142.1
    Mentioned
    67 Post(s)
    Rep Power
    22


    Reputation: Yes | No
    Did you drive through any door high water?




  4. #4
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    I didn't drive through any bigger than normal puddles yesterday. Nothing close to what you would consider a puddle worth worrying about - just your typical wet roads. The car didn't have any issues yesterday, only this morning right when I started it up. Either way it is damp in the engine bay, i'm assuming from the overnight rain. Just curious what kind of damage that could have caused? damp coil(s)? think this could just clear itself up when it dries?
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  5. #5
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    fyi, here are the code descriptions:


    2AB4 DME, internal error: RAM-checksum
    Error will cause a warning light
    Error is not currently present
    Test conditions have been completed
    Short circuit or signal interruption


    2EE6 cooling fluid sensor, measurement range


    2ABD Intake pressure sensor, re-running
    Error will not cause a warning light
    Error is not currently present
    Test conditions have been completed
    EXPLANATION: Map sensor connectivity issue.
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  6. #6
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    the ECU one scares the $#@! out of me... could it just be a hiccup? how can the car run if the DME is $#@!ed? it felt ok, the car wasn't shaking or anything out of the ordinary
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  7. #7
    Join Date
    Feb 2012
    Location
    Naples, FL
    Posts
    2,085
    Rep Points
    2,142.1
    Mentioned
    67 Post(s)
    Rep Power
    22


    Reputation: Yes | No
    Click here to enlarge Originally Posted by jpsimon Click here to enlarge
    the ECU one scares the $#@! out of me... could it just be a hiccup? how can the car run if the DME is $#@!ed? it felt ok, the car wasn't shaking or anything out of the ordinary
    How bad was the smoke? I don't know why you would have any smoke if you didn't suck up any water. Maybe it pulled some water from the intakes when you first started it up this morning?

    What intake are you running




  8. #8
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    I have dual cone intakes

    There's a chance the excessive smoke i saw was really just a ton of condensation in the exhaust since it's so $#@!ty outside. My first thought was smoke since it had the engine malfunction. I'm hoping the sun comes out so things dry up a bit.. clear codes, go to the shop.. hope for the best..
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  9. #9
    Join Date
    Feb 2012
    Location
    Naples, FL
    Posts
    2,085
    Rep Points
    2,142.1
    Mentioned
    67 Post(s)
    Rep Power
    22


    Reputation: Yes | No
    Click here to enlarge Originally Posted by jpsimon Click here to enlarge
    I have dual cone intakes

    There's a chance the excessive smoke i saw was really just a ton of condensation in the exhaust since it's so $#@!ty outside. My first thought was smoke since it had the engine malfunction. I'm hoping the sun comes out so things dry up a bit.. clear codes, go to the shop.. hope for the best..
    Pretty much, I wouldn't be too worried, sensors could also have gotten condensation on them, or your ECU box could have leaked a little. (If you have additional wires going into it)

    I wouldn't be TOO worried.




  10. #10
    Join Date
    Oct 2011
    Posts
    1,057
    Rep Points
    1,149.5
    Mentioned
    39 Post(s)
    Rep Power
    12


    Reputation: Yes | No
    Im betting the smoke was condensation as well. The internal short circuit doesnt sound too good. DMEs are a straight swap, if for just a startup test, no?

  11. #11
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    are they?
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  12. #12
    Join Date
    Feb 2013
    Location
    Maryland
    Posts
    1,554
    Rep Points
    2,516.8
    Mentioned
    67 Post(s)
    Rep Power
    26


    Reputation: Yes | No
    Yea a DME swap, while expensive, isn't as much of a nightmare as it would seem. As I understand it, at least.

    OP I bet you are OK. Maybe the car was just being an ass, it happens. My guess is condensation in the exhaust.
    E88 N54 Alpinweiss/Coral Red/Motiv HTA 3586r Tial .82AR/Motiv Port Fuel/BMR 3.5" Exhaust/ER CP/Synapse/VRSF FMIC/Rob Beck PCV Valve + Cap/ST Coilovers/M3 FCA + Tension Rods/M3 Subframe Bushings/M3 FSB/AA Strutbrace/DINAN Camber Plates/Apex ARC-8/Project Kics/VAC Hubs/Rogue Transmission Mounts/Alpina TCU Flash/Icarbon/Kerscher/BMW Performance
    F30 335 X-Drive EBII....PPK otherwise Stock
    Click here to enlarge

  13. #13
    Join Date
    Apr 2012
    Posts
    37
    Rep Points
    26.0
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    I just got that 2EE6 Coolant Temp gradient blah blah. Your electric fan kick on when you get that code. I delete and restarted and the car was fine. There is still a lot of speculation as to why we get the 2EE6 but some people have said it has something to do with WG duty. I'd guess that your DME code is prob related to condensation. Let it idle and get warm to burn off that moisture and see if it comes back.

  14. #14
    Join Date
    Feb 2013
    Location
    Maryland
    Posts
    1,554
    Rep Points
    2,516.8
    Mentioned
    67 Post(s)
    Rep Power
    26


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Vertigo44 Click here to enlarge
    I just got that 2EE6 Coolant Temp gradient blah blah. Your electric fan kick on when you get that code. I delete and restarted and the car was fine. There is still a lot of speculation as to why we get the 2EE6 but some people have said it has something to do with WG duty. I'd guess that your DME code is prob related to condensation. Let it idle and get warm to burn off that moisture and see if it comes back.
    Every time I reflash a new map my car does that. Have no idea why. I clear it once, and it’s never an issue again. But whenever I flash a new map and start it for the first time, the fan goes nuts and I think the waterpump is shot. Weird…
    E88 N54 Alpinweiss/Coral Red/Motiv HTA 3586r Tial .82AR/Motiv Port Fuel/BMR 3.5" Exhaust/ER CP/Synapse/VRSF FMIC/Rob Beck PCV Valve + Cap/ST Coilovers/M3 FCA + Tension Rods/M3 Subframe Bushings/M3 FSB/AA Strutbrace/DINAN Camber Plates/Apex ARC-8/Project Kics/VAC Hubs/Rogue Transmission Mounts/Alpina TCU Flash/Icarbon/Kerscher/BMW Performance
    F30 335 X-Drive EBII....PPK otherwise Stock
    Click here to enlarge

  15. #15
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    that stuff doesn't bother me as much as the DME related one. gonna let it dry and see what happens... fingers crossed
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  16. #16
    Join Date
    Nov 2011
    Location
    Florida
    Posts
    903
    Rep Points
    785.5
    Mentioned
    113 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Was your cowl off ?

  17. #17
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    nope
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  18. #18
    Join Date
    Mar 2012
    Posts
    582
    Rep Points
    711.5
    Mentioned
    20 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    DME swap would entail coding your VIN, not sure of the actual technical process of that, just high level.

  19. #19
    Join Date
    Oct 2011
    Posts
    1,057
    Rep Points
    1,149.5
    Mentioned
    39 Post(s)
    Rep Power
    12


    Reputation: Yes | No
    Click here to enlarge Originally Posted by blisstik Click here to enlarge
    DME swap would entail coding your VIN, not sure of the actual technical process of that, just high level.
    $#@!, can't remember what was said on these forums. I thoguht only the injectors had to be coded? I'm probably mistaken.

  20. #20
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    update... car started on fire. just kidding, I cleared the codes this morning, started it up, and everything is fine. Guess it just needed to dry out
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  21. #21
    Join Date
    Oct 2011
    Posts
    1,057
    Rep Points
    1,149.5
    Mentioned
    39 Post(s)
    Rep Power
    12


    Reputation: Yes | No
    Good news. But it's concerning if the dampness was the root cause. Open up the ecubox and make sure it's sealed closed correctly?

  22. #22
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    yeah I need to get in there anyways this weekend, so i'll double check it's on there tight
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  23. #23
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    it's back...

    I can clear the code, start the car and it's gone: car drives fine. Turn it off, turn it back on and the limp mode comes back. Even though it says "reduced power" the power isn't actually reduced like a normal limp mode. the car drives fine

    this happens every time. clear code, drive around fine with no codes/errors. restart car and it throws the error

    wtf?
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  24. #24
    Join Date
    Feb 2013
    Location
    Maryland
    Posts
    1,554
    Rep Points
    2,516.8
    Mentioned
    67 Post(s)
    Rep Power
    26


    Reputation: Yes | No
    So it's just trolling with limp mode bells and whistles? Codes are the same? At least the voluminous smoke part of the equation is solved lol.
    E88 N54 Alpinweiss/Coral Red/Motiv HTA 3586r Tial .82AR/Motiv Port Fuel/BMR 3.5" Exhaust/ER CP/Synapse/VRSF FMIC/Rob Beck PCV Valve + Cap/ST Coilovers/M3 FCA + Tension Rods/M3 Subframe Bushings/M3 FSB/AA Strutbrace/DINAN Camber Plates/Apex ARC-8/Project Kics/VAC Hubs/Rogue Transmission Mounts/Alpina TCU Flash/Icarbon/Kerscher/BMW Performance
    F30 335 X-Drive EBII....PPK otherwise Stock
    Click here to enlarge

  25. #25
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    yeah the smoke must have just been condensation and the 2000000% humidity

    but yeah, I'm getting trolled by a limp mode that doesn't actually reduce power, which can be cleared and only comes back after the next time I start the car
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •