Close

Results 1 to 9 of 9
  1. #1
    Join Date
    Dec 2012
    Posts
    304
    Rep Points
    374.3
    Mentioned
    6 Post(s)
    Rep Power
    4


    Yes Reputation No

    White Smoke... PCV? Burning Oil? HELP

    It seems like the issues really never stop... Basically here's what happened. I updated my JB4 to firmware that Terry wanted me to try to get rid of my rattle and it worked. I took it on a test drive and was ridiculously happy, hadn't heard pure turbo spool in months.


    Anyways I continue driving light throttle to listen for rattle and start to feel a rumble like a misfire. I decide to turn autoclear off and go WOT so I can see which cylinder is misfiring. I do it then get my SES light and put the car in neutral. The RPM's drop to around 2k and it seems like the car is about to die and it's making a revving sound if I remember correctly. So I shut it off for a few seconds like normal. When I turn it back on SES light is still there and it's rough but i'm in the middle of the road so I accelerate lightly. Look back in my rearview and see a huge cloud of what looked to me like pure white smoke covering the road. Almost took a picture but by the time I got my phone out I was too far away.


    After traveling 100 yards the SES light was gone and it was back to running smooth so I could get home. Checked codes and it was cylinder 4 misfire. Yesterday was cylinder 5. I changed spark plugs about 8k ago, coil packs few weeks ago, and now have all bank 2 injectors waiting to be installed as soon as I can. My only problem is now with this white smoke i'm extremely worried. Any ideas...?


    My car has around 59.5k miles on it. I also checked oil level on the nav and noticed it's getting kinda low (see pic below). Oil was changed at 53k. It really does seem like it never ends with this car :mad0259: :cry:


    Click here to enlarge
    Click here to enlarge < Click picture for photoshoot
    E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
    Mods: JB4 + MHD, Doc Race ST, Pure 6266, AD-Eng PI/Mounts, Fuel-It st. 3, Custom Exhaust, Tuned by TwistedTuning
    More Pictures: Build Thread /// Dyno Soon to Come

  2. #2
    Join Date
    Nov 2010
    Posts
    404
    Rep Points
    758.8
    Mentioned
    11 Post(s)
    Rep Power
    8


    Yes Reputation No
    You probably don't want to hear this -- and I hope I'm wrong, but I fear that you may have a blown turbo.

    Neil

  3. #3
    Join Date
    Dec 2012
    Posts
    304
    Rep Points
    374.3
    Mentioned
    6 Post(s)
    Rep Power
    4



    Yes Reputation No
    Click here to enlarge Originally Posted by MDORPHN Click here to enlarge
    You probably don't want to hear this -- and I hope I'm wrong, but I fear that you may have a blown turbo.

    Neil
    Yea definitely not what I want to hear and what i'm hoping isn't the case... Tomorrow morning once the car is cool i'm going to check the coolant levels. First and foremost I think I should replace the injectors. This is the first incident of any smoke i've ever had or at least that i've known of
    Click here to enlarge < Click picture for photoshoot
    E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
    Mods: JB4 + MHD, Doc Race ST, Pure 6266, AD-Eng PI/Mounts, Fuel-It st. 3, Custom Exhaust, Tuned by TwistedTuning
    More Pictures: Build Thread /// Dyno Soon to Come

  4. #4
    Join Date
    Jul 2010
    Posts
    79
    Rep Points
    47.0
    Mentioned
    6 Post(s)
    Rep Power
    0


    Yes Reputation No
    Your engine will not run rough from a blown turbo. I bet you have some leaking injector. Will give a witish/blue fume and smells very plastic/oil/spicey...

  5. #5
    Join Date
    Oct 2011
    Location
    Dallas, TX
    Posts
    626
    Rep Points
    1,088.2
    Mentioned
    14 Post(s)
    Rep Power
    11


    Yes Reputation No
    could also be little as the primary o2 sensors shot. but I've heard of issues being o2s.

    my turbos boosted great when the seals were shot, car had new injectors, coils, plugs, o2s, RB PCV, and valvcover gasket, as well as clean intakevlaves. smoke persisted. was the turbos then pulled the trigger on RBs.
    Click here to enlarge
    Instagram: Sammy0559
    VTX3's Click here to enlarge
    Got one more tow with AAA lets make it count Click here to enlarge

  6. #6
    Join Date
    Aug 2012
    Location
    Tallahassee
    Posts
    1,484
    Rep Points
    -23.8
    Mentioned
    34 Post(s)
    Rep Power
    0


    Yes Reputation No
    I told him that I think it's a faulty check valve. Internet diagnosis is tough.

  7. #7
    Join Date
    Dec 2012
    Posts
    304
    Rep Points
    374.3
    Mentioned
    6 Post(s)
    Rep Power
    4



    Yes Reputation No
    Click here to enlarge Originally Posted by RTA Click here to enlarge
    Your engine will not run rough from a blown turbo. I bet you have some leaking injector. Will give a witish/blue fume and smells very plastic/oil/spicey...
    Yea that's what I thought was weird. Terry said it was maybe a leaky injector dumping fuel or something like that. I do get some rough idles and cold starts the exhaust sound cuts in and out if you know what I mean. I think my first step in diagnosis is going to be swapping the injectors
    Click here to enlarge < Click picture for photoshoot
    E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
    Mods: JB4 + MHD, Doc Race ST, Pure 6266, AD-Eng PI/Mounts, Fuel-It st. 3, Custom Exhaust, Tuned by TwistedTuning
    More Pictures: Build Thread /// Dyno Soon to Come

  8. #8
    Join Date
    Dec 2012
    Posts
    304
    Rep Points
    374.3
    Mentioned
    6 Post(s)
    Rep Power
    4



    Yes Reputation No
    Click here to enlarge Originally Posted by sammy_0559 Click here to enlarge
    could also be little as the primary o2 sensors shot. but I've heard of issues being o2s.

    my turbos boosted great when the seals were shot, car had new injectors, coils, plugs, o2s, RB PCV, and valvcover gasket, as well as clean intakevlaves. smoke persisted. was the turbos then pulled the trigger on RBs.
    I would love to do upgraded turbos but as of right now can't afford them. That's why i'm praying it's not the turbos.
    Click here to enlarge < Click picture for photoshoot
    E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
    Mods: JB4 + MHD, Doc Race ST, Pure 6266, AD-Eng PI/Mounts, Fuel-It st. 3, Custom Exhaust, Tuned by TwistedTuning
    More Pictures: Build Thread /// Dyno Soon to Come

  9. #9
    Join Date
    Oct 2011
    Location
    Dallas, TX
    Posts
    626
    Rep Points
    1,088.2
    Mentioned
    14 Post(s)
    Rep Power
    11


    Yes Reputation No
    Click here to enlarge Originally Posted by psmith95 Click here to enlarge
    I would love to do upgraded turbos but as of right now can't afford them. That's why i'm praying it's not the turbos.
    it shouldn't be Click here to enlarge
    Click here to enlarge
    Instagram: Sammy0559
    VTX3's Click here to enlarge
    Got one more tow with AAA lets make it count Click here to enlarge

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •