Close

Results 1 to 9 of 9
  1. #1
    Join Date
    Mar 2011
    Location
    Birmingham, United Kingdom
    Posts
    204
    Rep Points
    269.3
    Mentioned
    8 Post(s)
    Rep Power
    3


    Reputation: Yes | No

    Error codes and limp mode after installing Aquamist HFS-4

    Hi guys,

    I've got a PTF pump gas tune on my car (mods in sig) and just fitted my Aquamist system with 0.9 and 1.0 nozzle. Unfortunately I had an issue with the system not running right and managed to spray full off throttle for a few seconds.

    Unfortunately now I seem to have reoccuring codes mainly on and now off meth and can't use WOT in 3rd. The car shakes and splutters and the engine completely shuts down. I also get a Flat tyre monitoring error at the same time.

    The codes are as follows:

    2C7C - Lambda probe behind catalytic converter 2, signal
    2AAF - Fuel pump plausibility
    2D59 - DME digital motor electronics, internal failure: control actual torque

    Any idea guys? I think I've got a brand new rear o2 sensor but its a splice in one so I'm not to keen on chopping up my wiring.
    Alpine White 2008 6MT 335i - Cobb AP - PTF Tuned - RB Turbos - AR DPs - VRSF 3.5" exhaust - Custom FMIC - 380mm BBK F&R - BMS DCI - M3 DCT LSD - Whiteline subframe bushes - M3 Sways and rear arms - M3 wishbones - ER CP - Spec Stage 3+ clutch and steel SMFW - AST 4100 Coilovers - UUC DSSR -UUC Black tranny mounts - TMS Alu diff bushes - Forge DVs - Aquamist HFS-4 meth - Alufelgen CS7s - BMWP V1 Steering Wheel

  2. #2
    Join Date
    Mar 2011
    Location
    Birmingham, United Kingdom
    Posts
    204
    Rep Points
    269.3
    Mentioned
    8 Post(s)
    Rep Power
    3



    Reputation: Yes | No
    Just reset the ECU with my cobb AP and did a third gear pull and everything seems fine. So it appears that everytime it has happened is on meth or just after spraying. I don't think I'm spraying too much as I've seen people run the same sort of nozzles as me with no adverse effects. My nozzles are placed 3 inches away from the intercooler outlet and the other (smaller 0.9 one) by the DV's on my ER CP.
    Alpine White 2008 6MT 335i - Cobb AP - PTF Tuned - RB Turbos - AR DPs - VRSF 3.5" exhaust - Custom FMIC - 380mm BBK F&R - BMS DCI - M3 DCT LSD - Whiteline subframe bushes - M3 Sways and rear arms - M3 wishbones - ER CP - Spec Stage 3+ clutch and steel SMFW - AST 4100 Coilovers - UUC DSSR -UUC Black tranny mounts - TMS Alu diff bushes - Forge DVs - Aquamist HFS-4 meth - Alufelgen CS7s - BMWP V1 Steering Wheel

  3. #3
    Join Date
    Feb 2012
    Location
    NoVA, DC, MD
    Posts
    66
    Rep Points
    405.6
    Mentioned
    37 Post(s)
    Rep Power
    5


    2 out of 2 members liked this post. Reputation: Yes | No
    Check the failsafe window, check your pinout in the dme to ensure it is 100% correct and that each connection is solid.

  4. #4
    Join Date
    Mar 2011
    Location
    Birmingham, United Kingdom
    Posts
    204
    Rep Points
    269.3
    Mentioned
    8 Post(s)
    Rep Power
    3



    Reputation: Yes | No
    Thanks Jake I'll get the failsafe setup before trying anything else. I did shorten up the injector piggyback wiring to prevent any interference issues which I felt cause the problem in the first place.

    Any chance you could give me some info on how to setup the THRES trimmer? I currently have it at the default 42% setting.
    Alpine White 2008 6MT 335i - Cobb AP - PTF Tuned - RB Turbos - AR DPs - VRSF 3.5" exhaust - Custom FMIC - 380mm BBK F&R - BMS DCI - M3 DCT LSD - Whiteline subframe bushes - M3 Sways and rear arms - M3 wishbones - ER CP - Spec Stage 3+ clutch and steel SMFW - AST 4100 Coilovers - UUC DSSR -UUC Black tranny mounts - TMS Alu diff bushes - Forge DVs - Aquamist HFS-4 meth - Alufelgen CS7s - BMWP V1 Steering Wheel

  5. #5
    Join Date
    May 2012
    Location
    Jacksonville, FL
    Posts
    2,933
    Rep Points
    2,826.5
    Mentioned
    78 Post(s)
    Rep Power
    29


    1 out of 1 members liked this post. Reputation: Yes | No
    What are you trying to accomplish by changing the settings @idnan?
    2011 E90 M3 \ Melbourne Rot Metallic

    Click here to enlarge

  6. #6
    Join Date
    Mar 2011
    Location
    Birmingham, United Kingdom
    Posts
    204
    Rep Points
    269.3
    Mentioned
    8 Post(s)
    Rep Power
    3



    Reputation: Yes | No
    Click here to enlarge Originally Posted by lulz_m3 Click here to enlarge
    What are you trying to accomplish by changing the settings @idnan?
    I was curious as to whether the system required further setup. Having spoken to Richard@Aquamist, he's given me some really helpful information to sorting out the problems and given me a good starting point to work from.
    Alpine White 2008 6MT 335i - Cobb AP - PTF Tuned - RB Turbos - AR DPs - VRSF 3.5" exhaust - Custom FMIC - 380mm BBK F&R - BMS DCI - M3 DCT LSD - Whiteline subframe bushes - M3 Sways and rear arms - M3 wishbones - ER CP - Spec Stage 3+ clutch and steel SMFW - AST 4100 Coilovers - UUC DSSR -UUC Black tranny mounts - TMS Alu diff bushes - Forge DVs - Aquamist HFS-4 meth - Alufelgen CS7s - BMWP V1 Steering Wheel

  7. #7
    Join Date
    Apr 2013
    Location
    Portsmouth, NH
    Posts
    31
    Rep Points
    26.0
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Jake@PTF Click here to enlarge
    Check the failsafe window, check your pinout in the dme to ensure it is 100% correct and that each connection is solid.
    This.

    I just installed mine three weeks ago, and I was very careful to ensure I cut the correct wires and that every solder joint was as good as it could be. Lots of potential for connection problems in the ECU box.
    2008 135 GIAC Stage II Race File
    2011 335d Stock

  8. #8
    Join Date
    May 2012
    Location
    Jacksonville, FL
    Posts
    2,933
    Rep Points
    2,826.5
    Mentioned
    78 Post(s)
    Rep Power
    29


    Reputation: Yes | No
    Click here to enlarge Originally Posted by idnan Click here to enlarge
    I was curious as to whether the system required further setup. Having spoken to Richard@Aquamist, he's given me some really helpful information to sorting out the problems and given me a good starting point to work from.
    Do you mind sharing?
    2011 E90 M3 \ Melbourne Rot Metallic

    Click here to enlarge

  9. #9
    Join Date
    Mar 2011
    Location
    Birmingham, United Kingdom
    Posts
    204
    Rep Points
    269.3
    Mentioned
    8 Post(s)
    Rep Power
    3



    1 out of 1 members liked this post. Reputation: Yes | No
    Click here to enlarge Originally Posted by lulz_m3 Click here to enlarge
    Do you mind sharing?
    Well first of all I'm an epic fail and I couldn't setup the failsafe properly as I had the show IDC on gauge jumper setting on my board. So basically no matter what I did it kept showing 8 bars on my gauge as it was showing injector duty cycle rather than meth flow.

    He gave me clear instructions on what all the settings do and the reasons for and against for using IDC or boost to calculations. I was having issues with bog so he advised biasing towards IDC. All basic stuff but tbh I had no idea what I was doing until he explained everything to me.
    Alpine White 2008 6MT 335i - Cobb AP - PTF Tuned - RB Turbos - AR DPs - VRSF 3.5" exhaust - Custom FMIC - 380mm BBK F&R - BMS DCI - M3 DCT LSD - Whiteline subframe bushes - M3 Sways and rear arms - M3 wishbones - ER CP - Spec Stage 3+ clutch and steel SMFW - AST 4100 Coilovers - UUC DSSR -UUC Black tranny mounts - TMS Alu diff bushes - Forge DVs - Aquamist HFS-4 meth - Alufelgen CS7s - BMWP V1 Steering Wheel

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •