Close

Results 1 to 24 of 24
  1. #1
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0


    Reputation: Yes | No

    New OEM turbos w/ weird whistle. HELP

    Hey guys,

    I got new OEM turbos about a month ago, and have been trying to figure out what this awful noise is that happens with cold start or when randomly driving. I heard of turbo siren / whistle but that doesn't sound like my problem. Does anyone have any suggestions on how I could fix this? Click here to enlarge


  2. #2
    Join Date
    Oct 2011
    Location
    NY
    Posts
    1,958
    Rep Points
    2,641.0
    Mentioned
    49 Post(s)
    Rep Power
    27


    Reputation: Yes | No
    boost leak .... prob a coupler that is tightly connected but just sticking out of the clamp, those can act as an instrument....

    but it also sounds like an exhaust leak going on there too, so maybe either or or one of the two... , Jack it up and look at the Intercooler and downpipes

    id re take the video when the car was warm to eliminate the cold start

    If BMW did under warranty bring it straight back to them
    09 6AT 335i Coupe M-Sport - SOLD
    Current - 16 Jeep Wrangler - Few Mods
    Looking for a n54 project e90/e82

  3. #3
    Join Date
    Aug 2012
    Location
    Tallahassee
    Posts
    1,482
    Rep Points
    0.1
    Mentioned
    34 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    That's turbo siren Click here to enlarge

  4. #4
    Join Date
    Oct 2011
    Location
    NY
    Posts
    1,958
    Rep Points
    2,641.0
    Mentioned
    49 Post(s)
    Rep Power
    27


    Reputation: Yes | No
    or possibly turbo siren all thought unlikely if they are new, and since they just had all the said parts disconnected u may get away with just a 20 minute wrenching
    09 6AT 335i Coupe M-Sport - SOLD
    Current - 16 Jeep Wrangler - Few Mods
    Looking for a n54 project e90/e82

  5. #5
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    I brought it back to them once because of rattling downpipes and now this!! lol..

    heres a video a few seconds after cold start. not completely warmed up though.


  6. #6
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Thanks for the help guys I appreciate it.. The weird thing is it makes and holds boost...

  7. #7
    Join Date
    Aug 2012
    Location
    Tallahassee
    Posts
    1,482
    Rep Points
    0.1
    Mentioned
    34 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    I've extensively researched this. Some RB's even do it too. I wouldn't worry about it because it isn't anything that causes problems in my experience except for the sound. As long as boost targets are on point, and you arn't leaking oil, there is no problem. My old turbo set whined 2x as loud as your set. Louder when cold, quieter when warmed up.

  8. #8
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Yea very strange. Just wanted to check make sure it wasn't a problem. If it was a boost or exhaust leak it would show in the data logs right? Which looks OK from what i've been told.

  9. #9
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Click here to enlarge

  10. #10
    Join Date
    Oct 2011
    Location
    NY
    Posts
    1,958
    Rep Points
    2,641.0
    Mentioned
    49 Post(s)
    Rep Power
    27


    Reputation: Yes | No
    is the noise the same all the time?
    09 6AT 335i Coupe M-Sport - SOLD
    Current - 16 Jeep Wrangler - Few Mods
    Looking for a n54 project e90/e82

  11. #11
    Join Date
    Mar 2010
    Location
    Toronto, Canada
    Posts
    6,680
    Rep Points
    3,329.6
    Mentioned
    225 Post(s)
    Rep Power
    34


    Reputation: Yes | No
    vids are usually bad for analyzing sounds like that...however, for OEM turbos, you may have had something go through one of them...sounds too loud to be normal but again, hard to judge based on vids
    Click here to enlarge

  12. #12
    Join Date
    Sep 2012
    Location
    Harrisburg
    Posts
    1,284
    Rep Points
    1,526.3
    Mentioned
    43 Post(s)
    Rep Power
    16


    Reputation: Yes | No
    Maybe check the rear intake tube. That has a tendency to pop off.

    Just start by checking for things that are lose or disconnected. You could have have a helper rev up the car a bit while you poke around under the hood to isolate the area where the sound is coming from.
    Eppur si muove.

  13. #13
    Join Date
    May 2013
    Posts
    22
    Rep Points
    25.8
    Mentioned
    0 Post(s)
    Rep Power
    0


    1 out of 1 members liked this post. Reputation: Yes | No
    When I initially looked at the forums to find out what the whistling sound I heard was, I thought it was my turbos as well... turned out it wasn't and now I'm without a car waiting for them to finish the $3500 job of rebuilding my transmission (I tried linking to my thread regarding this, but I don't have enough rep points to post a link. You can find it by searching posts I've started...). Might as well spend whatever short time it takes to make sure your transmission fluid levels are ok, just in case...

    Good luck!

  14. #14
    Join Date
    Aug 2012
    Location
    Hayward, CA
    Posts
    7,907
    Rep Points
    3,899.8
    Mentioned
    320 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    That's not a boost leak, your turbos are just noisy for whatever reason. You can get one set that will be completely silent at full boost and another set that will sound like that. Unless it gets really really loud and does it anytime you make boost you are prob ok. But as D said its hard to tell from videos. a turbo being noisy is almost always a bad thing, but not 100% of the time. I know that doesn't help but honestly that doesn't sound that bad. Your only choice is to run it and see what happens unless you want to take it apart.

  15. #15
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10


    Reputation: Yes | No
    been through 5 sets of different turbos across 2 N54S, all of them got the siren sound after a while.

  16. #16
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Thanks for all your help and opinions. I will definitely check to see if anything is loose. The noise actually gets better ( less or hard to hear) once the car is all the way warmed up. I know its hard to tell from the video, but if I made a thread talking about a noise. I'm sure everyone would of said post a video lol
    Hope it's nothing too serious and doesn't get worse..

  17. #17
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    If something was loose would I still be able to make target boost??

  18. #18
    Join Date
    Nov 2011
    Location
    Florida
    Posts
    904
    Rep Points
    785.6
    Mentioned
    113 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Sounds normal to me compared to my Turbos. Mine have a high pitch whistling sound compared to yours in the vid has a lower pitch whistling sound.

    I been had this sound from since day one I bought the car new when rolling out the dealership

  19. #19
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Click here to enlarge Originally Posted by BuraQ Click here to enlarge
    I been had this sound from since day one I bought the car new when rolling out the dealership
    That's good to hear. Thats its normal and I'm not the only one. Click here to enlarge

  20. #20
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Click here to enlarge Originally Posted by dzenno@PTF Click here to enlarge
    you may have had something go through one of them
    Only thing I want going through them is boost! What do you think could have gone through them from your experience... ?

  21. #21
    Join Date
    Feb 2014
    Posts
    2
    Rep Points
    2.2
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Did you ever figure out what was causing the whistle sound? I am having the exact same problem new turbos 4k ago. Noticed the sound after having my hpfp replaced at the dealer but think is just a coincidence. Moved so taking it back to the mod friendly dealer is not a option.

  22. #22
    Join Date
    Jun 2010
    Location
    Boynton Beach, FL
    Posts
    1,209
    Rep Points
    1,445.2
    Mentioned
    61 Post(s)
    Rep Power
    0


    2 out of 2 members liked this post. Reputation: Yes | No
    The sound comes from the turbo inlets not being pushed all the way on.

  23. #23
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,838
    Rep Points
    31,573.4
    Mentioned
    2066 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by BoostAddict Click here to enlarge
    The sound comes from the turbo inlets not being pushed all the way on.
    Well that's simple.

    It's better than when I heard someone ask why their Jaguar XJR had a whine coming from the engine.

  24. #24
    Join Date
    Feb 2014
    Posts
    2
    Rep Points
    2.2
    Mentioned
    0 Post(s)
    Rep Power
    0


    1 out of 1 members liked this post. Reputation: Yes | No
    Thank you for your reply will check the inlets near the turbos. I hope that is all it is.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •