Close

Results 1 to 22 of 22
  1. #1
    Join Date
    Oct 2011
    Posts
    1,058
    Rep Points
    1,149.6
    Mentioned
    39 Post(s)
    Rep Power
    12


    Yes Reputation No

    How Many of You Have Changed O2 Sensors?

    And what mileage? Did you change front and rears? Any defining attribute in logs? I think I may have a lazy O2 sensor...

    It's been rumored that the rears do influence trimming control, and this is evident on other BMW chassis.

    Any input?

  2. #2
    Join Date
    May 2011
    Posts
    173
    Rep Points
    117.2
    Mentioned
    6 Post(s)
    Rep Power
    2


    1 out of 1 members liked this post. Yes Reputation No
    Just did mine. 93k miles. Front and back.

    I have a thread on here that's 4 pages long with my logs and issues. I am not convinced the O2 sensors made a lick of difference, but at least they are now ruled out as a potential cause.
    Last edited by stangorang; 07-16-2013 at 10:12 PM.

  3. #3
    Join Date
    Sep 2012
    Posts
    136
    Rep Points
    162.1
    Mentioned
    2 Post(s)
    Rep Power
    2


    3 out of 4 members liked this post. Yes Reputation No
    I did mine once because of way out wacky AFRs. Turns out the procede is just a piece of $#@! and installing a JB4 would have been a far more economical route to go.

  4. #4
    Join Date
    Aug 2012
    Location
    818
    Posts
    253
    Rep Points
    235.6
    Mentioned
    8 Post(s)
    Rep Power
    3


    Yes Reputation No
    did mine
    08 328i, totaled by women driver
    07 335i, lots of mods.
    Now- 14 Focus ST
    Click here to enlarge

  5. #5
    Join Date
    Dec 2012
    Posts
    302
    Rep Points
    374.1
    Mentioned
    6 Post(s)
    Rep Power
    4


    Yes Reputation No
    Did my two rear o2's a few weeks ago cause I kept getting misfires and a code for rear o2 sensor #2. Didn't really fix anything. Still have misfires and also getting rear o2 #2 codes again
    Click here to enlarge < Click picture for photoshoot
    E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
    Mods: JB4 + MHD, Doc Race ST, Pure 6266, AD-Eng PI/Mounts, Fuel-It st. 3, Custom Exhaust, Tuned by TwistedTuning
    More Pictures: Build Thread /// Dyno Soon to Come

  6. #6
    Join Date
    Mar 2010
    Location
    Stockholm
    Posts
    1,528
    Rep Points
    1,177.6
    Mentioned
    61 Post(s)
    Rep Power
    12


    Yes Reputation No
    Click here to enlarge Originally Posted by 135Hoser Click here to enlarge
    I did mine once because of way out wacky AFRs. Turns out the procede is just a piece of $#@! and installing a JB4 would have been a far more economical route to go.
    same happened to me.....
    07 335i AT - MOTIV 750 - MHD BMS E85 - BMS PI - JB4G5 - Okada Coils - NGK 5992 Plugs - Helix IC - Stett CP - Custom midpipes with 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - LUX H8 - Level 10 AT upgrade
    Click here to enlarge

  7. #7
    Join Date
    Apr 2010
    Location
    Mars, Gale Crater
    Posts
    873
    Rep Points
    682.4
    Mentioned
    53 Post(s)
    Rep Power
    7


    Yes Reputation No
    I'm at almost 100k miles now on the original o2 sensors
    335xi (sold)
    www.datazap.me - fast, free, interactive datalogs

    Click here to enlarge

  8. #8
    Join Date
    Oct 2012
    Posts
    109
    Rep Points
    218.2
    Mentioned
    5 Post(s)
    Rep Power
    3


    Yes Reputation No
    I replaced both precats after one died (flatlined AFR) and threw a code while on the dyno. It was at ~62000 miles.
    2008 335I E92, AW, VFF700, 18" Forgestar F14, M3 front/side, M-tech rear, AMS IC, H&R Touring Cup Kit suspension, HID AE, ER Charge Pipe & Synapse BOV, CIC Retrofit, Quafie, DSS, Defiv Lockdown, SPEC 2+/Steel SMFW, Walbro 450

  9. #9
    Join Date
    Jul 2012
    Location
    UK
    Posts
    107
    Rep Points
    482.0
    Mentioned
    8 Post(s)
    Rep Power
    5


    Yes Reputation No
    Replaced one front that was damaged by dp's too close to steering rack RHD all clear now but only by a few mm's
    Mods: Cobb v3, Aquamist hfs-4, BMS DCI, AR Design DP's, ETS FMIC, ETS Charge Pipe, HKS SSQV BOV, BMS CDV, BMS OCC, BMS Clutch Stop & ptf twin disc clutch.

  10. #10
    Join Date
    Oct 2012
    Location
    Colorado Springs, CO
    Posts
    88
    Rep Points
    65.1
    Mentioned
    4 Post(s)
    Rep Power
    0


    Yes Reputation No
    I replaced mine at around 53k miles. All sorts of codes were being thrown during any heavy throttle application, and idling was terrible. After replacing them, everything worked great. I have Procede + Flex Fuel.

  11. #11
    Join Date
    Nov 2010
    Posts
    404
    Rep Points
    758.8
    Mentioned
    11 Post(s)
    Rep Power
    8


    Yes Reputation No
    Getting ready to replace my pre-cat sensors.

    Neil

  12. #12
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10


    Yes Reputation No
    swapped a rear o2 sensor because of fuel mixture codes and cat errors unrelated to being catless, fixed the problem. 44k miles

    swapped a front o2 in bank 2 because of an AFR imbalance, resolved that too. 25k miles

  13. #13
    Join Date
    Apr 2013
    Posts
    132
    Rep Points
    112.4
    Mentioned
    2 Post(s)
    Rep Power
    2


    Yes Reputation No
    60K on mine no issues so far with the o2 sensors at-least... lol

  14. #14
    Join Date
    Apr 2013
    Location
    Los Angeles
    Posts
    64
    Rep Points
    76.0
    Mentioned
    2 Post(s)
    Rep Power
    0


    Yes Reputation No
    don't kill me for being wrong but aren't the o2 sensors covered under bmw emissions extended warranty

  15. #15
    Join Date
    Jul 2012
    Location
    UK
    Posts
    107
    Rep Points
    482.0
    Mentioned
    8 Post(s)
    Rep Power
    5


    Yes Reputation No
    Click here to enlarge Originally Posted by Marz Click here to enlarge
    don't kill me for being wrong but aren't the o2 sensors covered under bmw emissions extended warranty
    According to my local bmw dealer theres no extended emissions warranty like u guys have in USA. Shame as I have wastegate rattle.
    Mods: Cobb v3, Aquamist hfs-4, BMS DCI, AR Design DP's, ETS FMIC, ETS Charge Pipe, HKS SSQV BOV, BMS CDV, BMS OCC, BMS Clutch Stop & ptf twin disc clutch.

  16. #16
    Join Date
    Jan 2012
    Location
    Northern VA
    Posts
    111
    Rep Points
    200.4
    Mentioned
    13 Post(s)
    Rep Power
    3


    1 out of 1 members liked this post. Yes Reputation No
    Started seeing some AFR differences bank 1 versus 2, so I did both fronts at around 56k miles on mine, Procede + meth.

    Use the same bank 1 sensor for both banks, save some $. Bosch # 17098, fits banks 1&2 on N52 engine, but is only listed for bank 1 on the N54, while the bank 2 is 17102 and about twice as much as the 17098. No worries, the 17098 works in both banks on the N54, just different wire lengths. Make sure you label the sensor and plug end to ensure you don't mix them up.
    James Muskopf
    RRT Racing
    2007 E92 335i/6MT Procede Rev3 w/PWM meth, otherwise stock
    E28 M5, R171 SLK320

  17. #17
    Join Date
    Jun 2012
    Location
    North East
    Posts
    404
    Rep Points
    419.1
    Mentioned
    20 Post(s)
    Rep Power
    5


    Yes Reputation No
    Click here to enlarge Originally Posted by JamesM3M5 Click here to enlarge
    Started seeing some AFR differences bank 1 versus 2, so I did both fronts at around 56k miles on mine, Procede + meth.

    Use the same bank 1 sensor for both banks, save some $. Bosch # 17098, fits banks 1&2 on N52 engine, but is only listed for bank 1 on the N54, while the bank 2 is 17102 and about twice as much as the 17098. No worries, the 17098 works in both banks on the N54, just different wire lengths. Make sure you label the sensor and plug end to ensure you don't mix them up.

    Thank you for the tip!

    With the new sensors,, did this fix your AFR differences between bank 1 & 2..?
    For Sale:

    - NX Express complete wet kit with Plug & Play fuel adapter for BMW 335i

    - FBO parts here LINK


  18. #18
    Join Date
    Jan 2012
    Location
    Northern VA
    Posts
    111
    Rep Points
    200.4
    Mentioned
    13 Post(s)
    Rep Power
    3


    Yes Reputation No
    Yes it certainly did. I was seeing up to 0.5 difference in actual AFR (not trim). It also cured about 50% of the idle and low-load cruising stumble.
    James Muskopf
    RRT Racing
    2007 E92 335i/6MT Procede Rev3 w/PWM meth, otherwise stock
    E28 M5, R171 SLK320

  19. #19
    Join Date
    Oct 2011
    Posts
    1,058
    Rep Points
    1,149.6
    Mentioned
    39 Post(s)
    Rep Power
    12



    Yes Reputation No
    Thanks James. I did scribble down those Bosch PNs when you first made that thread on e90. I'm not chasing O2 sensors as priority at the moment, but it is on my list of things to do.

    edit: I also managed to find an O2 sensor test in INPA. It seems to test by running one bank at 0.9 lambda, and then 1.1 labma, and then the same for the other bank. I suppose it is matching expected vs actual reaction. Did you happen to try this test out before replacing your sensors @JamesM3M5?

  20. #20
    Join Date
    Jun 2012
    Location
    North East
    Posts
    404
    Rep Points
    419.1
    Mentioned
    20 Post(s)
    Rep Power
    5


    Yes Reputation No
    Click here to enlarge Originally Posted by Tzu Click here to enlarge
    Thanks James. I did scribble down those Bosch PNs when you first made that thread on e90. I'm not chasing O2 sensors as priority at the moment, but it is on my list of things to do.

    edit: I also managed to find an O2 sensor test in INPA. It seems to test by running one bank at 0.9 lambda, and then 1.1 labma, and then the same for the other bank. I suppose it is matching expected vs actual reaction. Did you happen to try this test out before replacing your sensors @JamesM3M5?
    Can you explain how you got to the INPA screen to run the O2 sensor test? I did not see that option or maybe that menu was in German Click here to enlarge
    For Sale:

    - NX Express complete wet kit with Plug & Play fuel adapter for BMW 335i

    - FBO parts here LINK


  21. #21
    Join Date
    Jan 2012
    Location
    Copenhagen, Denmark
    Posts
    115
    Rep Points
    299.2
    Mentioned
    4 Post(s)
    Rep Power
    3


    Yes Reputation No
    I recently changed all my O2 sensors because the trims were going a bit crazy, and the car threw mixture codes, O2 sensors error codes, SES yellow light and logs showed AFRs on bank 1 @ 12.6 and bank 2 @ 11.5 consistently under WOT.

    Unfortunately changing all 4 sensors (that really aren't that cheap) didn't do anything for my error codes and/or AFRs. I'm running a COBB ProTune and I'm at ~85k miles.

    I also changed my HPFP for the 3rd time, and fortunately that helped, so performance is now good again, but I don't really like the codes or trim/AFRs.

    So for the OP I would suggest that most likely nothing is wrong with your O2 sensors, the error may be somewhere else.
    E92 335i 2008 Space Grey 6MT | RB turbos | Quaife LSD | M3 Suspension kit | Íhlins Road & Track Coilover | DEFIVfab N54 diff lockdown kit | COBB PTF E50 map | Walbro E85 455 LPH LPFP | NGK 5992 plugs | Wagner FMIC | Wagner 3" DP | Milltek exhaust | Trueform Tech Intake System | Tial BOV | Motiv PI Stage 1 w/AIC | SPEC Stage 3+ clutch | SPEC SSM Flywheel | BMS CDV | 60-130 mph 7.55 s | 100-200 kmh 6.57 s

  22. #22
    Join Date
    Oct 2011
    Posts
    1,058
    Rep Points
    1,149.6
    Mentioned
    39 Post(s)
    Rep Power
    12



    Yes Reputation No
    Click here to enlarge Originally Posted by boosted-M Click here to enlarge
    Can you explain how you got to the INPA screen to run the O2 sensor test? I did not see that option or maybe that menu was in German Click here to enlarge
    Its in the diagnostics screen, forget which diag number at the moment. My copy is mostly in German too, but I just dicked around with it until I found new menus.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •