Close

Results 1 to 8 of 8
  1. #1
    Join Date
    Aug 2010
    Location
    over there
    Posts
    288
    Rep Points
    481.1
    Mentioned
    14 Post(s)
    Rep Power
    5


    Yes Reputation No

    low fuel pressure at idle

    I have a 335 with jb4 and cobb backend flash with the walbro 455lph. I installed this using Terrys diy with 225psi e85 rated lines and my lpfp only holds 50psi at idle. When i get in the gas it just drops pressure runs lean and misfires. Any ideas what this could be?
    Turbo lag is the on ramp to the highway which is power.

  2. #2
    Join Date
    Sep 2011
    Posts
    1,205
    Rep Points
    2,124.7
    Mentioned
    25 Post(s)
    Rep Power
    22


    Yes Reputation No
    Your Venturi likely came off. Mine came off again this weekend. At idle it was at 50psi. Put it back on and it was 72-84psi. 99.9% sure that is your problem.


    As this has happened twice to me, I'm going to tap the Venturi and use a longer nipple so the hose clamp will never come off.
    Change is constant

  3. #3
    Join Date
    Aug 2010
    Location
    over there
    Posts
    288
    Rep Points
    481.1
    Mentioned
    14 Post(s)
    Rep Power
    5



    Yes Reputation No
    Ill look into that im going to pull apart the fuel bucket tomorrow i figured out even though my line is rated for e85 and lots of psi its not submersible so going to get some better line and ill check that venturi out
    Turbo lag is the on ramp to the highway which is power.

  4. #4
    Join Date
    Mar 2010
    Location
    Stockholm
    Posts
    1,528
    Rep Points
    1,177.6
    Mentioned
    61 Post(s)
    Rep Power
    12


    Yes Reputation No
    Than one line probably bursted . Mine is probably off as well again, when i have little more than 1/4 tank it throws 29 dc error
    07 335i AT - MOTIV 750 - MHD BMS E85 - BMS PI - JB4G5 - Okada Coils - NGK 5992 Plugs - Helix IC - Stett CP - Custom midpipes with 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - LUX H8 - Level 10 AT upgrade
    Click here to enlarge

  5. #5
    Join Date
    Nov 2009
    Location
    Simi Valley, CA
    Posts
    8,074
    Rep Points
    9,057.9
    Mentioned
    637 Post(s)
    Rep Power
    91


    Yes Reputation No
    If you are having problems with the venturi the inline approach may prove easier to install for you: http://www.n54tech.com/forums/showthread.php?t=18956
    Burger Motorsports
    Home of the Worlds fastest N20s, N54s, N55s, N63s, S55s, and S63s!

    It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please see http://www.burgertuning.com/emissions_info.html for more information on legal requirements related to use of BMS parts.

  6. #6
    Join Date
    Aug 2010
    Location
    over there
    Posts
    288
    Rep Points
    481.1
    Mentioned
    14 Post(s)
    Rep Power
    5



    Yes Reputation No
    I dont have the stock pump parts or the inline walbro so that's a relatively expensive fix
    Turbo lag is the on ramp to the highway which is power.

  7. #7
    Join Date
    Aug 2010
    Location
    over there
    Posts
    288
    Rep Points
    481.1
    Mentioned
    14 Post(s)
    Rep Power
    5



    Yes Reputation No
    got it all fixed thanks guys it was a mix between bad line and the venturi holds 80 psi now at idle lol
    Turbo lag is the on ramp to the highway which is power.

  8. #8
    Join Date
    Sep 2011
    Posts
    1,205
    Rep Points
    2,124.7
    Mentioned
    25 Post(s)
    Rep Power
    22


    Yes Reputation No
    Woot! Welcome back
    Change is constant

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •