Close

Page 2 of 6 FirstFirst 1234 ... LastLast
Results 26 to 50 of 127
  1. #26
    Join Date
    Nov 2012
    Posts
    412
    Rep Points
    518.6
    Mentioned
    1 Post(s)
    Rep Power
    6


    Reputation: Yes | No
    Yeah it worked fine, paddles are back!

    Sending you some coin here in a bit, thanks for all your help with this.

  2. #27
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12



    Reputation: Yes | No
    Click here to enlarge Originally Posted by ajsalida Click here to enlarge
    Yeah it worked fine, paddles are back!

    Sending you some coin here in a bit, thanks for all your help with this.
    Enjoy man..Your going to love it!
    Click here to enlarge

  3. #28
    Join Date
    Feb 2013
    Posts
    2
    Rep Points
    6.2
    Mentioned
    0 Post(s)
    Rep Power
    0


    1 out of 1 members liked this post. Reputation: Yes | No
    Hi guys ...

    need a little adivce on this here ..
    flashing the ecu worked flawlessly, everything working as expected Click here to enlarge

    but when i try to code the egs with ncsexpert, im getting this error while "sg_codieren" is active ...

    Click here to enlarge

    any ideas whats going wrong ? (just did a complete fresh setup with 48.1 data...)
    Last edited by mdma666; 03-08-2013 at 04:41 PM.

  4. #29
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12



    Reputation: Yes | No
    @Sticky please update this first post and replace it with this one...Thank you



    *****Alpina B3 flash Part II: DIY for NOT-working paddles shifters after flash:


    The Alpina B3 flash has been a huge success so far for performance gains as well as fixing many issues that has plagued the N54 platform for years. It has undoubtedly given the performance gains in which everyone could enjoy. The only minor glitch during the flashing was on new model years in which once the car is flashed the paddle shifters now longer worked, unlike the earlier build model years which didn't exhibit this. This was quite bothersome to me so I had to find a fix as it seemed unthinkable it wouldn't work. Here is your solution!

    You guys need to use NCSexpert and have the latest SPdaten 48.1 loaded up to both NCSexpert and Ediabas. There are tons of literature on this so do a search on it. If you not comfortable doing this or the actual coding, you can find a local coder and pay to have this coded....

    Warning: If you dont have the Spdaten 48.1 udated correctly after doing this coding the car will be Dead and show a gear warning on cluster!!!

    ************************************************** ****************************************
    Here is what you do:




    0-Start ignition with cluster lights on
    1-Load NCSexpert
    2-File Use EXPERTMODE click ok
    3-(F1) Vin/ZCS/FA
    4-(F3) SG ausw
    5-Choose E89 chassis click ok
    6-Choose CAS click ok
    7-(F6) Back
    8-(F4) Read ECU and pick EGS module click ok
    9-wait till nettodat file pops up and then close it out
    10-Press F3 (execute JOB)
    11-After it says coding ended your done!
    12-Close out NCSexpert


    At this point 3 things can happen:


    **A)There are no errors and the car starts fine and the paddle shifters are working and your happy!


    **B)The car starts but then when you drive off, the shifting of gears are all screwy and changing correctly.


    **C)The car starts but you get the dreaded GEAR error and it wont even go into drive at all..
    .

    If you have either B or C then you issue is the update of the Spdaten 48.1 was incorrectly done...Go back and check installation and start again


    I have worked long and hard to get this Alpina B3 flash to where it is now so everyone can enjoy this without any glitches. If you feel that my DIY on Winkfp for flashing Alpina B3 flash and this DIY helped in anyway, and you would like to make a small contribution for my efforts, I would be grateful and appreciate it..If not thats cool too.

    My paypal addy is
    ccnoner@aol.com


    Enjoy the flash!
    Click here to enlarge

  5. #30
    Join Date
    Nov 2010
    Location
    Netherlands
    Posts
    6,192
    Rep Points
    6,728.5
    Mentioned
    73 Post(s)
    Rep Power
    68


    Reputation: Yes | No
    This looks a lot easier then the previous DIY Click here to enlarge
    Less steps means less opportunity to $#@! up.
    Great work once again!
    There are two theories to arguing with women. Neither one works

  6. #31
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,195
    Rep Points
    31,312.9
    Mentioned
    2056 Post(s)
    Rep Power
    314


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Cn555ic Click here to enlarge
    @Sticky please update this first post and replace it with this one...Thank you



    *****Alpina B3 flash Part II: DIY for NOT-working paddles shifters after flash:

    The Alpina B3 flash has been a huge success so far for performance gains as well as fixing many issues that has plagued the N54 platform for years. It has undoubtedly given the performance gains in which everyone could enjoy. The only minor glitch during the flashing was on new model years in which once the car is flashed the paddle shifters now longer worked, unlike the earlier build model years which didn't exhibit this. This was quite bothersome to me so I had to find a fix as it seemed unthinkable it wouldn't work. Here is your solution!

    You guys need to use NCSexpert and have the latest SPdaten 48.1 loaded up to both NCSexpert and Ediabas. There are tons of literature on this so do a search on it. If you not comfortable doing this or the actual coding, you can find a local coder and pay to have this coded....

    Warning: If you dont have the Spdaten 48.1 udated correctly after doing this coding the car will be Dead and show a gear warning on cluster!!!

    ************************************************** ****************************************
    Here is what you do:




    0-Start ignition with cluster lights on
    1-Load NCSexpert
    2-File Use EXPERTMODE click ok
    3-(F1) Vin/ZCS/FA
    4-(F3) SG ausw
    5-Choose E89 chassis click ok
    6-Choose CAS click ok
    7-(F6) Back
    8-(F4) Read ECU and pick EGS module click ok
    9-wait till nettodat file pops up and then close it out
    10-Press F3 (execute JOB)
    11-After it says coding ended your done!
    12-Close out NCSexpert


    At this point 3 things can happen:


    **A)There are no errors and the car starts fine and the paddle shifters are working and your happy!


    **B)The car starts but then when you drive off, the shifting of gears are all screwy and changing correctly.


    **C)The car starts but you get the dreaded GEAR error and it wont even go into drive at all..
    .

    If you have either B or C then you issue is the update of the Spdaten 48.1 was incorrectly done...Go back and check installation and start again


    I have worked long and hard to get this Alpina B3 flash to where it is now so everyone can enjoy this without any glitches. If you feel that my DIY on Winkfp for flashing Alpina B3 flash and this DIY helped in anyway, and you would like to make a small contribution for my efforts, I would be grateful and appreciate it..If not thats cool too.

    My paypal addy is
    ccnoner@aol.com


    Enjoy the flash!
    Done

  7. #32
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12



    Reputation: Yes | No
    @Sticky....I think the edit did not go through...can you please check it again...thanks
    Click here to enlarge

  8. #33
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,195
    Rep Points
    31,312.9
    Mentioned
    2056 Post(s)
    Rep Power
    314


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Cn555ic Click here to enlarge
    @Sticky ....I think the edit did not go through...can you please check it again...thanks
    Under part II? Looks like it did to me.

  9. #34
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12



    Reputation: Yes | No
    @Sticky please update this first post and replace it with this one..erase everything on first post and copy and paste this.






    *****Alpina B3 flash Part II: DIY for NOT-working paddles shifters after flash:




    The Alpina B3 flash has been a huge success so far for performance gains as well as fixing many issues that has plagued the N54 platform for years. It has undoubtedly given the performance gains in which everyone could enjoy. The only minor glitch during the flashing was on new model years in which once the car is flashed the paddle shifters now longer worked, unlike the earlier build model years which didn't exhibit this. This was quite bothersome to me so I had to find a fix as it seemed unthinkable it wouldn't work. Here is your solution!


    You guys need to use NCSexpert and have the latest SPdaten 48.1 loaded up to both NCSexpert and Ediabas. There are tons of literature on this so do a search on it. If you not comfortable doing this or the actual coding, you can find a local coder and pay to have this coded....


    Warning: If you dont have the Spdaten 48.1 udated correctly after doing this coding the car will be Dead and show a gear warning on cluster!!!


    ************************************************** ****************************************
    Here is what you do:








    0-Start ignition with cluster lights on
    1-Load NCSexpert
    2-File Use EXPERTMODE click ok
    3-(F1) Vin/ZCS/FA
    4-(F3) SG ausw
    5-Choose E89 chassis click ok
    6-Choose CAS click ok
    7-(F6) Back
    8-(F4) Read ECU and pick EGS module click ok
    9-wait till nettodat file pops up and then close it out
    10-Press F3 (execute JOB)
    11-After it says coding ended your done!
    12-Close out NCSexpert




    At this point 3 things can happen:




    **A)There are no errors and the car starts fine and the paddle shifters are working and your happy!




    **B)The car starts but then when you drive off, the shifting of gears are all screwy and changing correctly.




    **C)The car starts but you get the dreaded GEAR error and it wont even go into drive at all..
    .


    If you have either B or C then you issue is the update of the Spdaten 48.1 was incorrectly done...Go back and check installation and start again




    I have worked long and hard to get this Alpina B3 flash to where it is now so everyone can enjoy this without any glitches. If you feel that my DIY on Winkfp for flashing Alpina B3 flash and this DIY helped in anyway, and you would like to make a small contribution for my efforts, I would be grateful and appreciate it..If not thats cool too.


    My paypal addy is
    ccnoner@aol.com




    Enjoy the flash!
    Click here to enlarge

  10. #35
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12



    Reputation: Yes | No
    @Sticky....Please look at the first post and compare what I edited it...Just copy and paste post #34 exactly how I have it....The first post has too many steps and I fixed it...
    Click here to enlarge

  11. #36
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,195
    Rep Points
    31,312.9
    Mentioned
    2056 Post(s)
    Rep Power
    314


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Cn555ic Click here to enlarge
    @Sticky ....Please look at the first post and compare what I edited it...Just copy and paste post #34 exactly how I have it....The first post has too many steps and I fixed it...
    Ok done.

  12. #37
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12



    Reputation: Yes | No
    @Sticky. Almost perfect. Need to get rid of the picture at the very end of the first post. Don't mean to be a PITA but this has to be precise As people are following it step by step and some don't even have any experience in coding so anything extra will freak them out
    Click here to enlarge

  13. #38
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,195
    Rep Points
    31,312.9
    Mentioned
    2056 Post(s)
    Rep Power
    314


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Cn555ic Click here to enlarge
    @Sticky . Almost perfect. Need to get rid of the picture at the very end of the first post. Don't mean to be a PITA but this has to be precise As people are following it step by step and some don't even have any experience in coding so anything extra will freak them out
    It's no problem, removed.

  14. #39
    Join Date
    Mar 2013
    Posts
    9
    Rep Points
    7.9
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Trying to fix the paddle shifters... however i notice the NETTODAT.TRC file once I read the EGS is showing the following below
    B 00300000,0003,00,00,00

    and not the traditional
    EL_INTERLOCK
    nicht_aktiv
    NIC
    nicht_aktiv
    PADDLES
    wert_00
    SEAT
    wert_00
    OBD_pfc
    wert_00

    the car starts fine without errors and gears shift as intended. Any help on this I appreciated... thank you in advanced.

  15. #40
    Join Date
    Mar 2013
    Posts
    9
    Rep Points
    7.9
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Trying to fix the paddle shifters... however i notice the NETTODAT.TRC file once I read the EGS is showing the following below

    B 00300000,0003,00,00,00

    and not the traditional
    EL_INTERLOCK
    nicht_aktiv
    NIC
    nicht_aktiv
    PADDLES
    wert_00
    SEAT
    wert_00
    OBD_pfc
    wert_00

    the car starts fine without errors and gears shift as intended. Any help on this I appreciated... thank you in advanced.

  16. #41
    Join Date
    Mar 2013
    Posts
    9
    Rep Points
    7.9
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Trying to fix the paddle shifters... however i notice the NETTODAT.TRC file once I read the EGS is showing the following below

    B 00300000,0003,00,00,00

    and not the traditional
    EL_INTERLOCK
    nicht_aktiv
    NIC
    nicht_aktiv
    PADDLES
    wert_00
    SEAT
    wert_00
    OBD_pfc
    wert_00


    Why are my values showing in Hex and not plain text?
    the car starts fine without errors and gears shift as intended. Any help on this I appreciated... thank you in advanced.
    Last edited by melloww22; 03-18-2013 at 02:59 AM.

  17. #42
    Join Date
    Mar 2013
    Posts
    9
    Rep Points
    7.9
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    by the way i figured out why i was having a brain dump... doing coding at Midnight is not a good idea... heck ts 1:21 AM right now... Lesson learned... the FSW_PSW is in plain text, and the TRC files are in hex... DuUUHHHHHH...

    Anyways... once i took a 30 minute break to think it through... i found out why the confusion... problem fixed the hex in the NETTODAT should read

    B 00300000,0003,2B,14,00

    I am good to go...

  18. #43
    Join Date
    Nov 2011
    Posts
    85
    Rep Points
    147.0
    Mentioned
    5 Post(s)
    Rep Power
    2


    Reputation: Yes | No
    abit confused here, there were the following steps before/;

    ******PART 2******
    Go back to Part I ---- This time we want to change PADDLES back to wert_00 on step 9
    ******PART 3******

    1-Load NCSexpert
    2-File choose EXPERTMODE
    3-(F1) Vin/ZCS/FA
    4-(F3) SG Ausw
    5-Choose E89 chassis click ok
    6-Choose CAS
    7-(F6) Back
    8-(F4) Read ECU
    9-Choose EGS and click ok and wait till nettodat file pops up then close it
    10-(F3) Execute Job
    11-Close out NCSexpert
    12-Shut off car take key out and lock the door
    13-Start the car


    are these not necessary anymore ?

  19. #44
    Join Date
    Nov 2011
    Posts
    85
    Rep Points
    147.0
    Mentioned
    5 Post(s)
    Rep Power
    2


    Reputation: Yes | No
    looks like its reading the module only, and not writing?
    is that right?

  20. #45
    Join Date
    Mar 2013
    Posts
    9
    Rep Points
    7.9
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Click here to enlarge Originally Posted by neilvosko Click here to enlarge
    looks like its reading the module only, and not writing?
    is that right?
    I tried it with the new steps several times and it didnt work... However i just coded to wert_01, then wert_00 then read it and executed the EGS in exportmode and it worked...

    see my above post... by the way the key is to have updated your ncsexper and edibias correctly with v48.1

  21. #46
    Join Date
    Nov 2012
    Posts
    412
    Rep Points
    518.6
    Mentioned
    1 Post(s)
    Rep Power
    6


    Reputation: Yes | No
    Click here to enlarge Originally Posted by neilvosko Click here to enlarge
    looks like its reading the module only, and not writing?
    is that right?
    I think it was determined the changing back and forth from wert_00 to 01 back to 00 (old step 1 & 2) was unnecessary. What was necessary was writing the original settings back onto the EGS module, which can be done in expertmode as in step 3 above. Somehow on 09 and later cars it needed to be reminded to use the paddles after reflashing the EGS.

    edit: my original file actually said wert_02, which I changed to wert_01 and then to wert_00, and did step 3 and the paddles came back. So I have not actually verified that doing only step 3 would do it. But it seems obvious that writing back and forth to the same thing is not doing anything that just writing the original settings back wouldn't do. I still need to check and see if I have wert_00 or 02 now after all that.

  22. #47
    Join Date
    Nov 2011
    Posts
    85
    Rep Points
    147.0
    Mentioned
    5 Post(s)
    Rep Power
    2


    Reputation: Yes | No
    Yep, i agree with you here.
    had to do the expertmode to set to defaults, which ended up being wert_02.

  23. #48
    Join Date
    Nov 2011
    Posts
    85
    Rep Points
    147.0
    Mentioned
    5 Post(s)
    Rep Power
    2


    Reputation: Yes | No
    so i am wondering if this is necessary....basically the expertmode is reading the VO code to defaults.

  24. #49
    Join Date
    Mar 2012
    Posts
    57
    Rep Points
    92.8
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Where do we find the correct files and what folder do they need to be in?

  25. #50
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12



    Reputation: Yes | No
    Click here to enlarge Originally Posted by BMW86 Click here to enlarge
    Where do we find the correct files and what folder do they need to be in?
    What do you mean correct files? SPdaten V48.1 is where you find the data
    Click here to enlarge

Page 2 of 6 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •