Close

Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2011
    Posts
    1,590
    Rep Points
    2,018.0
    Mentioned
    10 Post(s)
    Rep Power
    21


    Yes Reputation No

    2013 BMW M6 (1 mile elevation - new record (not official)) - Got Lag?

    Very fast car, especially considering its "test" (if you can call it that) weight and mile high elevation. How these people test cars for a living is beyond me, they don't even understand why LC wasn't working. A little ridiculous/hard to take serious.

    Still, with two passengers - no Launch Control, and with 1 mi elevation - it was insanely fast. Easily 3.x at sea level and/or using LC.

    Nutty fast, but to me shows why all M cars should be NA. The lag of these turbos was incredibly apparent. How this is can be called an M is beyond me. Imagine being mid corner when the boost comes on like that.

    I know the lag is exaggerated from elevation, and no one would apply that much throttle mid corner, but still - seems way too non-responsive to have an M badge in my opinion... Wouldn't mind driving one though. Click here to enlarge

    Whichever link works:

    http://www.youtube.com/?v=VdlVhg-frCQ

  2. #2
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    120,245
    Rep Points
    32,699.3
    Mentioned
    2130 Post(s)
    Rep Power
    327


    Yes Reputation No
    These guys are annoying.

    Regardless, moved to 6 Series section.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •