Close

Results 1 to 7 of 7

Thread: Plug change

  1. #1
    Join Date
    Aug 2010
    Location
    over there
    Posts
    288
    Rep Points
    481.1
    Mentioned
    14 Post(s)
    Rep Power
    5


    1 out of 1 members liked this post. Reputation: Yes | No

    Plug change

    So i changed my spark plugs today for the first time in too long. These plugs have been in the car for close to 45k miles. Mods have been jb4 with meth then jb4 g5 iso 50/50 e85 the entire life of these plugs. I have a walbro sitting in my house waiting to be installed this weekend as well as a cobb so the lean issues will be solved but these plugs look like **** to be honest all pictures from left to right are 1-6
    Click here to enlarge Click here to enlarge Click here to enlarge
    Turbo lag is the on ramp to the highway which is power.

  2. #2
    Join Date
    Oct 2011
    Posts
    1,057
    Rep Points
    1,149.5
    Mentioned
    39 Post(s)
    Rep Power
    12


    Reputation: Yes | No
    Looks like your 2 and 3 are covered in oil. Have you done VCG?

  3. #3
    Join Date
    Jul 2012
    Posts
    235
    Rep Points
    172.7
    Mentioned
    4 Post(s)
    Rep Power
    2


    Reputation: Yes | No
    whats vcg valve cover gasket?
    ground control coilovers/wavetrac lsd/ full m3 suspension/delrin bushings/ megan racing toe and camber arms/bmw oem performance carbon fiber front lip and rear deck spoiler/m3 strut brace/ecs SS brakelines/CPE dci's, charge pipe, catless dp, fmic/bms OCC/tuningtechfs custom tune/defiv diff lockdownkit,rbpcv valve.

  4. #4
    Join Date
    May 2011
    Location
    Houston, Texas
    Posts
    1,640
    Rep Points
    2,149.8
    Mentioned
    68 Post(s)
    Rep Power
    22


    Reputation: Yes | No
    Click here to enlarge Originally Posted by TRES Click here to enlarge
    whats vcg valve cover gasket?
    Yes
    2010 e92 M3 Jet Black | DCT | ESS Tuned | Akrapovic Slip-on | Challenge X-pipe | AFE Intake | 18" Volk TE37SL | KW V3 Coilovers | RPI Scoops | Under Drive Pulley

    2007 e92 Mont. Blue 335i | 6MT | COBB Tuned | Quaife 3.46 LSD | Helix FMIC | AA DPs | HKS Exhaust | DCI | Stett CP w/ Forged DVs | KWv2 Coilovers | UUC Sway Bars & SSK | HPF Stg 2 Clutch | HFS-4 | M3 Suspension Bits | DEFIVfab Diff Lockdown Kit | Stoptech Trophy BBK

  5. #5
    Join Date
    May 2011
    Location
    Dallas TX
    Posts
    499
    Rep Points
    517.1
    Mentioned
    10 Post(s)
    Rep Power
    6


    Reputation: Yes | No
    @WDBi so how is car performing with new plugs? Any issues?Were you having misfire issue before change or just changing because it was way overdue? I had the same oil on 2 and 3 and my issue was vcg. Just curious about your results as im going to the same plugs. GL and thanks in advance.

  6. #6
    Join Date
    Aug 2010
    Location
    over there
    Posts
    288
    Rep Points
    481.1
    Mentioned
    14 Post(s)
    Rep Power
    5



    Reputation: Yes | No
    Click here to enlarge Originally Posted by jzeee037 Click here to enlarge
    @WDBi so how is car performing with new plugs? Any issues?Were you having misfire issue before change or just changing because it was way overdue? I had the same oil on 2 and 3 and my issue was vcg. Just curious about your results as im going to the same plugs. GL and thanks in advance.
    i actually possibly spilled oil onto the plugs and the misfire issue is fixed now but i have a new problem with a bad injector i think
    Turbo lag is the on ramp to the highway which is power.

  7. #7
    Join Date
    May 2011
    Location
    Dallas TX
    Posts
    499
    Rep Points
    517.1
    Mentioned
    10 Post(s)
    Rep Power
    6


    Reputation: Yes | No
    That sucks. Please post your findings with the injector.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •