Close

Results 1 to 20 of 20

Thread: Leaking at Charge Pipe/Diverter Valve Seal

              
  1. #1
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    2 out of 2 members liked this post. Reputation: Yes | No

    Leaking at Charge Pipe/Diverter Valve Seal

    My DVs were not making a proper seal to the charge pipe as evidenced by oil/dirt buildup at the base of one of them. The raised boost must have been blowing oil past the o-ring at the base of the DV. I have attempted to solve this by ordering a slightly larger o-ring that fits more snuggly against the DV shaft. So far it seems this will have solved the problem just from how much tighter the seal feels. I have cleaned the area and will check back in a week to see if the problem is solved.

    The part number I ordered was McMaster 9262K553. 3.5mm wide with 24mm ID. The new o-ring is on the right and is only slightly thicker than the old one (but thats the point). If anyone else has leaking DV seals, PM me and I can mail you some.
    Attached Images Attached Images  

  2. #2
    Join Date
    Jun 2012
    Location
    NJ
    Posts
    4,136
    Rep Points
    1,771.0
    Mentioned
    100 Post(s)
    Rep Power
    18


    Reputation: Yes | No
    Still using the OEM CP/DVs?
    COBB AP ProTune by Bren of ///Bren Tuning
    Akrapovic DP | Helix FMIC | Alpina TCM Flash | Walbro 450LPH Fuel Pump


    "The moment money becomes your motivation, you are immediately not as good as someone who is motivated by passion and internal will." -A. Senna

  3. #3
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    Reputation: Yes | No

    Click here to enlarge Originally Posted by benzy89 Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    Still using the OEM CP/DVs?
    Yes sir.

  4. #4
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    105,304
    Rep Points
    25,718.8
    Mentioned
    1673 Post(s)
    Rep Power
    258


    Reputation: Yes | No
    Click here to enlarge Originally Posted by rudypoochris Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    If anyone else has leaking DV seals, PM me and I can mail you some.
    Very nice of you.

  5. #5
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    Reputation: Yes | No

    This has fixed a part throttle thump/surge/hiccup I would get during spool up. I guess the boost leak was varying the vacuum to the solenoids and causing them to stick or something. If you have a part throttle thump or hiccup, check for vacuum leaks (I thought I needed walnut blasting). In either case, better drivability and there is no new oil/dirt build up. So far so good.

  6. #6
    Join Date
    Nov 2012
    Location
    Naples, Fl
    Posts
    756
    Rep Points
    855.8
    Mentioned
    17 Post(s)
    Rep Power
    9


    Reputation: Yes | No
    Click here to enlarge Originally Posted by rudypoochris Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    This has fixed a part throttle thump/surge/hiccup I would get during spool up. I guess the boost leak was varying the vacuum to the solenoids and causing them to stick or something. If you have a part throttle thump or hiccup, check for vacuum leaks (I thought I needed walnut blasting). In either case, better drivability and there is no new oil/dirt build up. So far so good.
    I need to check this when i get home! I have moderate throttle hiccups when he boost kicks in. Full throttle is fine though...

  7. #7
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    Reputation: Yes | No

    Click here to enlarge Originally Posted by Eric335 Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    I need to check this when i get home! I have moderate throttle hiccups when he boost kicks in. Full throttle is fine though...
    That is when it happens. Especially if you stab the throttle and then lift. Or if you go light throttle like 15% after having done a bunch of WOT runs back to back. It could be a boost leak elsewhere too. Who knows. This is just what it was for me.

  8. #8
    Join Date
    Jun 2010
    Location
    Boynton Beach, FL
    Posts
    1,117
    Rep Points
    1,226.6
    Mentioned
    57 Post(s)
    Rep Power
    13


    Reputation: Yes | No
    I wish in would have saw this thread before I ordered new dv's.

    Authorized Dealer of: BMS, Evolution Racewerks, ETS, and more

  9. #9
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    1 out of 1 members liked this post. Reputation: Yes | No

    Click here to enlarge Originally Posted by BoostAddict Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    I wish in would have saw this thread before I ordered new dv's.
    You got surges? Oil/dirt at base of DV?

  10. #10
    Join Date
    Jun 2010
    Location
    Boynton Beach, FL
    Posts
    1,117
    Rep Points
    1,226.6
    Mentioned
    57 Post(s)
    Rep Power
    13


    Reputation: Yes | No
    Click here to enlarge Originally Posted by rudypoochris Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    You got surges? Oil/dirt at base of DV?
    surging, yes. I have a feeling my dv's are just blowing open, but it would have been nice to try this out first. Oh well.

    Authorized Dealer of: BMS, Evolution Racewerks, ETS, and more

  11. #11
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    Reputation: Yes | No

    Click here to enlarge Originally Posted by BoostAddict Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    surging, yes. I have a feeling my dv's are just blowing open, but it would have been nice to try this out first. Oh well.
    Its only a light hiccup/thump for me. Now its gone. Well, let us know if new DVs fixes it...

  12. #12
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    Reputation: Yes | No

    Did you guys receive the o-rings? Any noticeable difference? Still leaking?

  13. #13
    Join Date
    Sep 2011
    Posts
    801
    Rep Points
    949.4
    Mentioned
    16 Post(s)
    Rep Power
    10


    Reputation: Yes | No
    Not yet installed. It's a PITA to take the intercollegiate down the pressurize system. I did this previously and it did leak from those seals.

    Will report back.
    Beast Mode

  14. #14
    Join Date
    Jan 2011
    Posts
    1
    Rep Points
    0.1
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    I have the thump when you go from light throttle to WOT(it's really driving me crazy). I also have dirt and oil around the diverter valve. How hard is the o-ring replacement, and where can I buy these exact o-rings from?

  15. #15
    Join Date
    Feb 2012
    Location
    Naples, FL
    Posts
    1,918
    Rep Points
    1,686.1
    Mentioned
    55 Post(s)
    Rep Power
    17


    Reputation: Yes | No
    Great tips hope it helps everyone, I went out and bought forge DV's when I thought they where leaking. Ended up being a cracked end tank on the stock FMIC (before i upgraded)

    GL everyone




  16. #16
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    Reputation: Yes | No

    Click here to enlarge Originally Posted by The Ghost Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    Not yet installed. It's a PITA to take the intercollegiate down the pressurize system. I did this previously and it did leak from those seals.

    Will report back.
    Confused by the PITA part, but I advise using a small eye glass screw driver to pull the old rings out.

  17. #17
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    Reputation: Yes | No

    Click here to enlarge Originally Posted by timo1980 Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    I have the thump when you go from light throttle to WOT(it's really driving me crazy). I also have dirt and oil around the diverter valve. How hard is the o-ring replacement, and where can I buy these exact o-rings from?
    The PN is in the first post. I still got some though and can send to you if you need. Just PM me.

  18. #18
    Join Date
    Sep 2011
    Posts
    801
    Rep Points
    949.4
    Mentioned
    16 Post(s)
    Rep Power
    10


    Reputation: Yes | No
    Click here to enlarge Originally Posted by The Ghost Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    Not yet installed. It's a PITA to take the intercollegiate down the pressurize system. I did this previously and it did leak from those seals.

    Will report back.
    iPhone auto-complete for the lose!

    I meant, it's a PITA to take the FMIC partially off in order to pressurize the entire system. For those thinking you have a leak, I would pressure test it before buying replacement parts.
    Beast Mode

  19. #19
    Join Date
    Jun 2012
    Posts
    1,177
    Rep Points
    791.6
    Mentioned
    14 Post(s)
    Rep Power
    8


    Reputation: Yes | No

    Click here to enlarge Originally Posted by The Ghost Click here to enlarge
    This quote is hidden because you are ignoring this member. Show Quote
    iPhone auto-complete for the lose!

    I meant, it's a PITA to take the FMIC partially off in order to pressurize the entire system. For those thinking you have a leak, I would pressure test it before buying replacement parts.
    Haha, awesome. I am not building up oil/dirt there anymore, but your method is a lot more sound and should get the smaller leaks. Try a few pressures btw. Since mine was stumbling only at part throttle, that would seem to indicate that at low boost it would leak and when full boost hit it MAY have sealed. Either that or potentially the inverse.

  20. #20
    Join Date
    Feb 2014
    Posts
    1
    Rep Points
    2.1
    Mentioned
    0 Post(s)
    Rep Power
    0


    1 out of 1 members liked this post. Reputation: Yes | No
    I had this same issue. O rings are available on ebay for 4.50 for two.

    Thanks OP for the idea. The grey connector things are easy to take out once you see how they are held in.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •