Close

Results 1 to 9 of 9
  1. #1
    Join Date
    Apr 2010
    Location
    USA
    Posts
    650
    Rep Points
    731.7
    Mentioned
    16 Post(s)
    Rep Power
    8


    Yes Reputation No

    Warm/Cold misfire cylinder 3. Interesting.

    Well I had some misfire issues on cold start, and finally a injector gave up (stuck open) on a cold start, dealer changed all 3 injectors on bank2 (4,5,6)

    Cold start misfires were gone and car was running great. Also changed the plugs right before they changed my injectors.

    Now here is my issue... bank1 (1,2,3) still has the old injectors.

    When I fully warm the car after a drive, then park the car.. After I let the car sit for say 2-3 hours, oil temp back down to lowest temp on the gauge (160). I go to start her, and it rumbles and shakes until the rpms settle to a easy nice idle.. But during that rumble, I get a cylinder 3 misfire.

    Does this sound like somewhat of a injector issue again?
    Cold starts are great. WOT car is running and logging perfect. PLugs are new. Injectors 4,5,6 are new. Misfire only on cylinder 3 no other codes.

    Only happens when the car is warm, and I let it sit for a few hours and go back to start it.

    27k miles, FBO, 93 octane. No meth or E85 at the moment.
    ///M5 LCI
    "It's like the F10 is the 911 Turbo to the E60's GT3" -Pistonheads (M5 feature)

  2. #2
    Join Date
    Dec 2011
    Location
    Clarksville, TN
    Posts
    3,896
    Rep Points
    2,482.0
    Mentioned
    44 Post(s)
    Rep Power
    25


    Yes Reputation No
    Leaky injector for sure. I have the same thing. I just replaced injectors 5&6 and most of my rough idle is gone. i have a slight hickup every once in a while and i'm sure it's another injector. a very smart person on here said that when multiple injectors start to go it's best to replace all 6. That's what I'm going to do.
    2011 335is DCT, JB4 + MHD BEF, stage 2 LPFP, e50 + 50/50 meth, FBO, MT ET Streets when needed


  3. #3
    Join Date
    Apr 2010
    Location
    USA
    Posts
    650
    Rep Points
    731.7
    Mentioned
    16 Post(s)
    Rep Power
    8



    Yes Reputation No
    Click here to enlarge Originally Posted by bigdnno98 Click here to enlarge
    Leaky injector for sure. I have the same thing. I just replaced injectors 5&6 and most of my rough idle is gone. i have a slight hickup every once in a while and i'm sure it's another injector. a very smart person on here said that when multiple injectors start to go it's best to replace all 6. That's what I'm going to do.
    Yea makes sense but the damn dealer wouldn't change the other 3 on bank 1.. Just weird that it doesn't happen on coldstart... Only a few hours after its warm and sits is when it does it.
    ///M5 LCI
    "It's like the F10 is the 911 Turbo to the E60's GT3" -Pistonheads (M5 feature)

  4. #4
    Join Date
    Apr 2010
    Posts
    254
    Rep Points
    328.3
    Mentioned
    11 Post(s)
    Rep Power
    4


    Yes Reputation No
    Click here to enlarge Originally Posted by 5soko Click here to enlarge
    Yea makes sense but the damn dealer wouldn't change the other 3 on bank 1.. Just weird that it doesn't happen on coldstart... Only a few hours after its warm and sits is when it does it.
    That might be when it's leaking.

  5. #5
    Join Date
    Apr 2010
    Location
    USA
    Posts
    650
    Rep Points
    731.7
    Mentioned
    16 Post(s)
    Rep Power
    8



    Yes Reputation No
    Click here to enlarge Originally Posted by bigdnno98 Click here to enlarge
    Leaky injector for sure. I have the same thing. I just replaced injectors 5&6 and most of my rough idle is gone. i have a slight hickup every once in a while and i'm sure it's another injector. a very smart person on here said that when multiple injectors start to go it's best to replace all 6. That's what I'm going to do.
    Click here to enlarge Originally Posted by DCAFS Click here to enlarge
    That might be when it's leaking.
    Brought it to the dealer this am, and got it back this afternoon. Like I described, I was getting a cyl 3 misfire, after the car would sit for a few hrs... never during driving or WOT, only during starting. So the said that they found cyl 3 spark plug to be fouled (I just changed the plugs not too long ago, 4K miles) and the coil had spark marks or something on it, they replaced the coil aswell. IF it was the plug being fouled or coil, wouldn't this misfire be persistent? Im gonna try to make this cyl 3 misfire come back again tomorrow, if I could. Only makes sense that's its a leaky injector. Well see if the misfire comes back.
    ///M5 LCI
    "It's like the F10 is the 911 Turbo to the E60's GT3" -Pistonheads (M5 feature)

  6. #6
    Join Date
    Dec 2011
    Location
    Clarksville, TN
    Posts
    3,896
    Rep Points
    2,482.0
    Mentioned
    44 Post(s)
    Rep Power
    25


    Yes Reputation No
    When I replaced my 2 injectors recently I actually just cleaned the plugs and put them back in. They only had 1k miles on them. I still have somewhat of a stumble/miss at idle but I'm suspecting it's another injector not a sparkplug. I guess it could be. Keep us updated. I may use this as an excuse to get the NGK plugs Click here to enlarge
    2011 335is DCT, JB4 + MHD BEF, stage 2 LPFP, e50 + 50/50 meth, FBO, MT ET Streets when needed


  7. #7
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0


    Yes Reputation No
    your motors about to blow, get out now, buy an M3, dont look back Click here to enlarge

  8. #8
    Join Date
    Dec 2011
    Location
    Clarksville, TN
    Posts
    3,896
    Rep Points
    2,482.0
    Mentioned
    44 Post(s)
    Rep Power
    25


    Yes Reputation No
    Click here to enlarge Originally Posted by LostMarine Click here to enlarge
    your motors about to blow, get out now, buy an M3, dont look back Click here to enlarge
    I've already picked out my next car. It's a 2015 50th anniversary Mustang GT. Pre-order April 2014.
    2011 335is DCT, JB4 + MHD BEF, stage 2 LPFP, e50 + 50/50 meth, FBO, MT ET Streets when needed


  9. #9
    Join Date
    Apr 2010
    Location
    USA
    Posts
    650
    Rep Points
    731.7
    Mentioned
    16 Post(s)
    Rep Power
    8



    Yes Reputation No
    Just to update this thread: few weeks back I brought it to the dealer for the cyl 3 misfire. They said they found the plug was fouled and coil was bad. They replaced the plug and the coil.... Fast forward now, since then ive been making my car try to misfire but it hasn't so I thought the plug or coil was fouled, even tho that made no sense since my plugs were new nd never had a coil problem. One day I go to check the codes for fun, and cyl 3 misfire is back. I brought it to the dealer 2 days ago, they said they swapped injectors and are trying to make it misfire but cant. 40 miles and car wont misfire. So im picking the car up today, they said if it misfires again then they will change the injectors. So retarted.. So now I have to make it misfire again and bring it back.
    ///M5 LCI
    "It's like the F10 is the 911 Turbo to the E60's GT3" -Pistonheads (M5 feature)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •