Close

Results 1 to 13 of 13
  1. #1
    Join Date
    Aug 2012
    Posts
    43
    Rep Points
    17.9
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No

    Quick question need answer fast, so I can order the part! UUC DSSR (HELP)

    So I just put in a spec stage 3+ clutch and new fly wheel. (which feels amazing). But I notice that I have a hard time getting into 1st and reverse. So I'm thinking the clutch needs to break in. I get home and its starting to bother me. I Also have a UUC STS, and just decided to put in the DSSR today along with the new clutch. So I thought the STS needed to be adjusted to make the throws longer, as I investigate I see the UUC DSSR hitting the top of the shifter assembly! Which is causing me to no fully get into 1st or reverse! Now I have a 08 production date so I thought I was in the clear, my DSSR has no bend in it but my stock shifter did. Is there a right side up and a wrong side down on this thing. I can see that one side is flat and the other is round. Or do I simply have the wrong piece? sorry for the rant. And help. Click here to enlarge

  2. #2
    Join Date
    Aug 2012
    Posts
    43
    Rep Points
    17.9
    Mentioned
    0 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Come on anyone!?

  3. #3
    Join Date
    Mar 2012
    Posts
    582
    Rep Points
    711.5
    Mentioned
    20 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    Let me get this straight, do you think if you revert to stock, you won't have this problem right? So it looks like its either the installation is incorrect or the wrong part number was sent. Call UUC to verify part numbers on the actual part (if its there) versus what's on the invoice.

  4. #4
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,826
    Rep Points
    31,567.3
    Mentioned
    2065 Post(s)
    Rep Power
    316


    Reputation: Yes | No

  5. #5
    Join Date
    Aug 2012
    Posts
    43
    Rep Points
    17.9
    Mentioned
    0 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Talked to UUC and sent picture, they think possibly improper install. This did not happen prior to the DSSR install. I can see the DSSR hitting the carrier when I take off the boot and the insulation.

  6. #6
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,826
    Rep Points
    31,567.3
    Mentioned
    2065 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Sounds like it most likely is the install, let us know.

  7. #7
    Join Date
    Jan 2012
    Location
    Northern VA
    Posts
    111
    Rep Points
    200.4
    Mentioned
    13 Post(s)
    Rep Power
    3


    Reputation: Yes | No
    I don't know whether they're a sponsor here, but I have had too many bad/wrong parts from those guys to ever use anything again. Blame gets put on installation when it can be shown with no question that the part was wrong or defective. I've had to fix too many screwed up wrong parts or poorly fitting parts.
    James Muskopf
    RRT Racing
    2007 E92 335i/6MT Procede Rev3 w/PWM meth, otherwise stock
    E28 M5, R171 SLK320

  8. #8
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,826
    Rep Points
    31,567.3
    Mentioned
    2065 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by JamesM3M5 Click here to enlarge
    I don't know whether they're a sponsor here, but I have had too many bad/wrong parts from those guys to ever use anything again. Blame gets put on installation when it can be shown with no question that the part was wrong or defective. I've had to fix too many screwed up wrong parts or poorly fitting parts.
    UUC? No they are not.

  9. #9
    Join Date
    Aug 2012
    Posts
    43
    Rep Points
    17.9
    Mentioned
    0 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Update it was installed fine, just didn't work. So I took it out and shaved it down, and problem fixed. IMHO not worth it. Slop isn't that greatly improved. I also have their short throw which is ehhh. Now that I fixed it ill leave it for now and in the fututre maybe swap out the whole set up with a stock selector rod and bmw PSK.

  10. #10
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,826
    Rep Points
    31,567.3
    Mentioned
    2065 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by 3-Serious Click here to enlarge
    Update it was installed fine, just didn't work. So I took it out and shaved it down, and problem fixed. IMHO not worth it. Slop isn't that greatly improved. I also have their short throw which is ehhh. Now that I fixed it ill leave it for now and in the fututre maybe swap out the whole set up with a stock selector rod and bmw PSK.
    Well at least you figured it out, sucks it seems the part wasn't the right spec.

  11. #11
    Join Date
    Mar 2012
    Location
    Cleveland TN
    Posts
    541
    Rep Points
    554.0
    Mentioned
    16 Post(s)
    Rep Power
    6


    1 out of 1 members liked this post. Reputation: Yes | No
    Glad you were able to get one it took them 4 months to get me mine. Too bad I already tore the car apart to replace the diff, exhaust, DP's and had everything easy to get to. Not very excited to get under it and tear it apart just for a shifter rod.

  12. #12
    Join Date
    Aug 2012
    Posts
    43
    Rep Points
    17.9
    Mentioned
    0 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Yeah It sucks that I had to adjust it! And brusk keep us posted on how it the install goes. You can do it with out taking the car apart. I did it on jack stands and with just the under panels taken off and reached around the drive shaft.

  13. #13
    Join Date
    Mar 2012
    Location
    Cleveland TN
    Posts
    541
    Rep Points
    554.0
    Mentioned
    16 Post(s)
    Rep Power
    6


    Reputation: Yes | No
    Click here to enlarge Originally Posted by 3-Serious Click here to enlarge
    Yeah It sucks that I had to adjust it! And brusk keep us posted on how it the install goes. You can do it with out taking the car apart. I did it on jack stands and with just the under panels taken off and reached around the drive shaft.
    Ok had no interest in hurrying to do just that part but if you guys want maybe I'll get to it this weekend and see how it goes.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •