Close

Results 1 to 25 of 25
  1. #1
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0


    1 out of 1 members liked this post. Yes Reputation No

    Weird codes, anyone know what these mean?

    // 1) 27B2 Secondary air system throughput main section
    // 2) 2722 fuel pressure sensor electr. Diagnostics
    // 3) 2788 fuel pressure variance comparison at max pressure
    // 4) 2796 Motor emergency programm activated

    anyone gotten these before? Fuel pressure is 1 bar high at idle, was an issue prio to s/c install, but seems boost has aggravated the issue. top of 4th gear i get a limp mode now

    Not sure if BMW will cover it, so Im trying to expidite fixing the issue, but not sure if its a sensor, or actual pump isse, and if so, left or right..

    any insight?

  2. #2
    Join Date
    Aug 2010
    Location
    Valley Stream NY
    Posts
    3,350
    Rep Points
    2,779.7
    Mentioned
    85 Post(s)
    Rep Power
    28


    Yes Reputation No
    I wonder where the fp sensor is. Maybe we could try changing it.

  3. #3
    Join Date
    Feb 2010
    Location
    West LA
    Posts
    178
    Rep Points
    3.0
    Mentioned
    6 Post(s)
    Rep Power
    0


    1 out of 1 members liked this post. Yes Reputation No
    Click here to enlarge Originally Posted by LostMarine Click here to enlarge
    // 1) 27B2 Secondary air system throughput main section
    // 2) 2722 fuel pressure sensor electr. Diagnostics
    // 3) 2788 fuel pressure variance comparison at max pressure
    // 4) 2796 Motor emergency programm activated

    anyone gotten these before? Fuel pressure is 1 bar high at idle, was an issue prio to s/c install, but seems boost has aggravated the issue. top of 4th gear i get a limp mode now

    Not sure if BMW will cover it, so Im trying to expidite fixing the issue, but not sure if its a sensor, or actual pump isse, and if so, left or right..

    any insight?

    for 27B2:
    This happens when sls_obdh_lam_asv_intg_norm is above threshold

    You should:
    1. Check secondary air-injection pump pump/relay/valves
    2. Check main line for reduction in effective internal diameter
    3. Check mini-HFM


    2722:
    This happens when the fuel pressure sensor value transmitted to the DME was higher than the maximum value stored for this sensor

    You should:
    1. Delete the fault and see if it returns
    2. If it does check the plug and wiring harness at the sensor
    3. if the wiring is ok replace the sensor


    2788: This can be triggered in many different ways. It is specifically Fuel pressure, setpoint/actual-value comparison at max. pressure.

    Fuel pressure too high at maximum pressure
    Mutual deviation between specified/actual pressure > K_Sensor_OBD_Q_Max (this is the name for the max pres value set in the code)

    1. there is a test routine that can be done with the factory computer to test the system
    2. check your fuel filter
    3. check the fuel pressure sensor and wiring

    The above two faults will cause 2796 so that just means emergency program activated.

    Good luck

  4. #4
    Join Date
    Apr 2010
    Posts
    178
    Rep Points
    213.6
    Mentioned
    10 Post(s)
    Rep Power
    3


    1 out of 1 members liked this post. Yes Reputation No
    The 1st fault is normal for charged cars that are using the MAP sensor to read boost. The 2nd 2 faults show something is up with your fuel pressure. Last fault is limp mode from the fuel pressure faults.

  5. #5
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0



    Yes Reputation No
    It's goin back to dealer on thursday, the sensor is easy, its at the back seat bolster.. that's the cheapest and easiest fix.

  6. #6
    Join Date
    Nov 2010
    Location
    le Paris
    Posts
    6,648
    Rep Points
    -165.0
    Mentioned
    48 Post(s)
    Rep Power
    0


    Yes Reputation No
    I got the 3rd code when some guy added water to the tank. Took us 1 week to figure out what was the cause.

  7. #7
    Join Date
    Aug 2010
    Posts
    880
    Rep Points
    594.0
    Mentioned
    23 Post(s)
    Rep Power
    6


    Yes Reputation No
    If you think its related to the blower email AJ he will take care of you, but if the problem existed before the blower I'm not sure..

  8. #8
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    119,468
    Rep Points
    32,152.1
    Mentioned
    2109 Post(s)
    Rep Power
    322


    Yes Reputation No
    Not related to the blower if he had it previously.

    Stage 2 or 2.5 E9X M3 S65 V8 supercharger kit for sale
    : http://www.boostaddict.com/showthrea...r-kit-for-sale

  9. #9
    Join Date
    Jun 2011
    Location
    Pittsburgh, PA
    Posts
    804
    Rep Points
    641.4
    Mentioned
    6 Post(s)
    Rep Power
    7


    Yes Reputation No
    Click here to enlarge Originally Posted by LostMarine Click here to enlarge
    It's goin back to dealer on thursday, the sensor is easy, its at the back seat bolster.. that's the cheapest and easiest fix.
    Hope that fixes it. Good info in this thread.

  10. #10
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0



    Yes Reputation No
    I just want it pinpointed, covered or not, just so i don't have to replace working parts with working parts.

    The odd thing is that I let the car sit,.started it today and scanned codes, one of them was no longer present, 2722. I hope I'm not wasting time again by bringing it while its not currently limping..

  11. #11
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0



    Yes Reputation No
    I just want it pinpointed, covered or not, just so i don't have to replace working parts with working parts.

    The odd thing is that I let the car sit,.started it today and scanned codes, one of them was no longer present, 2722. I hope I'm not wasting time again by bringing it while its not currently limping..

  12. #12
    Join Date
    Aug 2010
    Posts
    880
    Rep Points
    594.0
    Mentioned
    23 Post(s)
    Rep Power
    6


    Yes Reputation No
    ^I'm in the same boat as you. Honestly I've exhausted every means to see what my issue is and I am tired of it, so its as simple as removing the blower and leaving the headache with the dealer. Your VT1 is even EASIER to uninstall (probably can be done in a couple hours).

  13. #13
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0



    Yes Reputation No
    your killin me man..

  14. #14
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    119,468
    Rep Points
    32,152.1
    Mentioned
    2109 Post(s)
    Rep Power
    322


    Yes Reputation No
    Are these two issues related somehow?

    Stage 2 or 2.5 E9X M3 S65 V8 supercharger kit for sale
    : http://www.boostaddict.com/showthrea...r-kit-for-sale

  15. #15
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0



    Yes Reputation No
    mine and his? no, not even same ballpark

  16. #16
    Join Date
    Aug 2010
    Posts
    880
    Rep Points
    594.0
    Mentioned
    23 Post(s)
    Rep Power
    6


    Yes Reputation No
    not at all...my only issue is an annoying ticking sound I exprience at idle after the car gets hot with no CEL's or adverse effects on performance, and his is CEL related

  17. #17
    Join Date
    Jun 2011
    Location
    Pittsburgh, PA
    Posts
    804
    Rep Points
    641.4
    Mentioned
    6 Post(s)
    Rep Power
    7


    Yes Reputation No
    Click here to enlarge Originally Posted by ERM324 Click here to enlarge
    not at all...my only issue is an annoying ticking sound I exprience at idle after the car gets hot with no CEL's or adverse effects on performance, and his is CEL related
    Ticking? My car ticks also, always has - no SC...

  18. #18
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0



    Yes Reputation No
    Click here to enlarge Originally Posted by singletrack Click here to enlarge
    Ticking? My car ticks also, always has - no SC...
    as did mine in the cold, but his is very different from a "normal" sound we are familiar with

  19. #19
    Join Date
    Nov 2010
    Location
    le Paris
    Posts
    6,648
    Rep Points
    -165.0
    Mentioned
    48 Post(s)
    Rep Power
    0


    Yes Reputation No
    The ticking sound is the famous idle valve.

  20. #20
    Join Date
    Aug 2010
    Posts
    880
    Rep Points
    594.0
    Mentioned
    23 Post(s)
    Rep Power
    6


    Yes Reputation No
    Mine isnt idle valve, at least I think not. This guy actually just made a thread with his stock 2011-2011 m3 that has the same issue as mine and hes experiencing it right after his 1200 mile service: http://www.m3post.com/forums/showthread.php?t=727515

    Its weird im looking forward to seeing what it is.

  21. #21
    Join Date
    Nov 2010
    Location
    le Paris
    Posts
    6,648
    Rep Points
    -165.0
    Mentioned
    48 Post(s)
    Rep Power
    0


    Yes Reputation No
    I don't know. in M3post there was another dude with 2008 M3 having the same problem. It was the idle valve WHICH was replaced by the dealer earlier back.

  22. #22
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0



    Yes Reputation No
    You talking to erm or me, for a ticking or fuel issue?

  23. #23
    Join Date
    Nov 2010
    Location
    le Paris
    Posts
    6,648
    Rep Points
    -165.0
    Mentioned
    48 Post(s)
    Rep Power
    0


    Yes Reputation No
    Click here to enlarge Originally Posted by LostMarine Click here to enlarge
    You talking to erm or me, for a ticking or fuel issue?
    Ricky. The ticking noise. Click here to enlarge

  24. #24
    Join Date
    Apr 2010
    Posts
    178
    Rep Points
    213.6
    Mentioned
    10 Post(s)
    Rep Power
    3


    Yes Reputation No
    The ticking noise may be a bearing on it's way out. If you go under the car where does it sound like it's coming from?

  25. #25
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,462
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0



    Yes Reputation No
    Click here to enlarge Originally Posted by M&M Click here to enlarge
    The ticking noise may be a bearing on it's way out. If you go under the car where does it sound like it's coming from?
    Thats what he believes, car is under inspection currently. The sound was from the motor, not sure exaclty where he said

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •