Close

Page 2 of 2 FirstFirst 12
Results 26 to 29 of 29
  1. #26
    Join Date
    Aug 2010
    Location
    Valley Stream NY
    Posts
    3,327
    Rep Points
    2,780.2
    Mentioned
    85 Post(s)
    Rep Power
    28


    Yes Reputation No
    more pics of the DeLorean!!!!!

  2. #27
    Join Date
    Aug 2010
    Location
    Valley Stream NY
    Posts
    3,327
    Rep Points
    2,780.2
    Mentioned
    85 Post(s)
    Rep Power
    28


    Yes Reputation No
    oh and welcome btw LOL

  3. #28
    Join Date
    Apr 2012
    Location
    Melbourne FL
    Posts
    99
    Rep Points
    166.6
    Mentioned
    11 Post(s)
    Rep Power
    2



    Yes Reputation No
    Thanks, you can see all of the pics in my album if you click in the links i posted.

  4. #29
    Join Date
    Apr 2012
    Location
    Melbourne FL
    Posts
    99
    Rep Points
    166.6
    Mentioned
    11 Post(s)
    Rep Power
    2



    1 out of 1 members liked this post. Yes Reputation No
    I finally had the time to do some things I have been meaning to get to. From the first time i pulled the lower cover under the engine, I noticed an oil leak from the pan. I cleaned it a few times but it came back each time. Dealer thought it was the drain plug but it was dry when all else was wet. I noticed it was coming from a hole that is part of the casting in the pan so I cleaned it up real well and filled it with JB weld putty. Now the engine should stay nice and clean.

    Click here to enlarge

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •