Close

Page 2 of 2 FirstFirst 12
Results 26 to 30 of 30
  1. #26
    Join Date
    May 2010
    Location
    South Jersey
    Posts
    860
    Rep Points
    1,537.7
    Mentioned
    26 Post(s)
    Rep Power
    16


    Reputation: Yes | No
    Sorry I didn't read this thread 3 days ago. I would have told you it sounded like a battery issue (just from what I've read everywhere else). I got a slew of lights related to the ABS/traction issue the other day that were gone the next time I drove the car. If they come back, the battery will be my first suspect.

  2. #27
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,460
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Click here to enlarge Originally Posted by BES335xi Click here to enlarge
    Martin from MNC Performance, Lynbrook, you might know him, idk.
    Havent towed it yet nor planned it but after gettin ripped off from a guy here local to me in queens ive found martin, it was during ur move to acm that i went ...

    On iphone today...sorry for any typos or what not...
    do it right and have it towed to matt@autocouture there is a reason i drive 2 hours to get work done..

  3. #28
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,826
    Rep Points
    31,567.3
    Mentioned
    2065 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by BavarianBullet Click here to enlarge
    I thought it was relatively well known at least on some other bmw xdrive models that the xdrive elec actuator that applies pressure to the xdrive clutch packs in the transfer case sometimes fails. This will turn on all the lights you have as the xdrive ties into those systems and they work together. When xdrive has a problem, all are flagged.

    It sounds like it could be as simple as a bad electrical connection to a failed actuator. If the actuator died it's supposedly pretty easy to fix, don't need to pull the transfer case or anything. Just a few hudno for the actuator, change it out and possibly recode dme for the changed part. There is an annoying voice in this video but it explains the process. http://www.youtube.com/watch?v=MkTO6d-eYkA

    It is likely not a major trans problem based on my limited knowledge but you never know. Try a few things yourself re investigating it then dealer it if you have to.

    Good luck with it!
    Nice post! Way to help out.

  4. #29
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,826
    Rep Points
    31,567.3
    Mentioned
    2065 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    So what's the verdict? Just the battery?

  5. #30
    Join Date
    Feb 2012
    Location
    QB, NYC
    Posts
    88
    Rep Points
    171.5
    Mentioned
    0 Post(s)
    Rep Power
    2



    Reputation: Yes | No
    Click here to enlarge Originally Posted by Sticky Click here to enlarge
    So what's the verdict? Just the battery?
    Dont know yet, my mechanic will tell me tommorrow sometime when he has time to diagnose it, He's a certified bmw mechanic and has done work on my car before and i trust him, so all i'm hoping for is that it doesnt turn out to be something major.
    JB4+usb | BMS OCC | P3 Vent Boost Gauge v2 | BMS DCI | AMS FMIC | AR xi CL DP's | BT Tool | ER CP + Forge DVs | Cyba Quad Exhaust tips | M-Tech Rear & M3 Front Bumpers | Cyba Red Air Scoops | Blacklines | Vinyl Overlays | ACS Roof Spoiler | Matte Black Grilles | LED Side Mirrors | Rear Euro Fogs | Matte Black Window Trim | 30% Tints | Sports & Winter package | Black Leather Int. | Aluminium Trim | & a few other things...Tuned by: Burger Motorsports.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •