Close

Page 1 of 2 12 LastLast
Results 1 to 25 of 50

Thread: blue smoke?

  1. #1
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10


    Reputation: Yes | No

    blue smoke?

    After like 8 back to back to back pulls 0-130/140 with zero cooldown, my buddy told me I was blowing blue smoke after I let off but not when I'm going WOT. digital dipstick says I'm half full (lost half a quart). I need to stop beating on this car so hard without cooldown Click here to enlarge

    I have an OCC if that means anything. Car didn't throw a single code and runs fine, idles perfectly. Is this normal?

  2. #2
    Join Date
    Mar 2010
    Location
    Toronto, Canada
    Posts
    6,676
    Rep Points
    3,291.4
    Mentioned
    225 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Sounds very much like turbo seal slowly on its way out...get ready for some RB fun Click here to enlarge

  3. #3
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by dzenno Click here to enlarge
    Sounds very much like turbo seal slowly on its way out...get ready for some RB fun Click here to enlarge
    i can warranty the sucker Click here to enlarge stock turbos ftw!

  4. #4
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    I guess what I'm more afraid of is if it's valve seals or piston rings.

    If it's only the turbos crapping out I'd actually be happy with that Click here to enlarge

    Or it could simply be the PCV system and there's too much crankcase pressure and the abrupt swing from positive to negative pressure sucking all the vapor into my intake. Doesn't help that I still have the BSH OCC installed.

  5. #5
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,460
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Ta..Ta..Ta..Ta..Turbo's...

  6. #6
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by LostMarine Click here to enlarge
    Ta..Ta..Ta..Ta..Turbo's...
    At 28k miles? lol. At least I know turbo replacement won't require a visit from a field tech from Germany. Click here to enlarge If I blew my motor or tranny, that's another story.

  7. #7
    Join Date
    Mar 2010
    Location
    Toronto, Canada
    Posts
    6,676
    Rep Points
    3,291.4
    Mentioned
    225 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    most likely turbos...too many, including myself, had very similar issues...fully catless exhaust?

  8. #8
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by dzenno Click here to enlarge
    most likely turbos...too many, including myself, had very similar issues...fully catless exhaust?
    stock exhaust, but no cats.

  9. #9
    Join Date
    Mar 2010
    Location
    Toronto, Canada
    Posts
    6,676
    Rep Points
    3,291.4
    Mentioned
    225 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Click here to enlarge Originally Posted by themyst Click here to enlarge
    stock exhaust, but no cats.
    maybe its been there all along if you only had someone just now follow your car around...a tiny bit of smoke may be just fine fully catless

  10. #10
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by dzenno Click here to enlarge
    maybe its been there all along if you only had someone just now follow your car around...a tiny bit of smoke may be just fine fully catless
    yeah but I've never dropped a half quart of oil from full before. Hopefully it's just the PCV system telling me to piss off after so many hard runs. I'm definitely NOT blowing blue smoke on a cold start so I don't think it's valve seals.

    Car hits boost instantly no problem, they wail a bit, especially on the race map, and when cold, but its nothing that much worse than what I had on the 135i.

    There is no obvious symptom telling me something's wrong other than the losing of a half quart of oil.

  11. #11
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    On another note, isn't Helix offering up their turbos + install for $3200? I believe that comes with a tune as well.

  12. #12
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,460
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    not sure about tune, but a free dyno, on a mustang dyno

  13. #13
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by LostMarine Click here to enlarge
    not sure about tune, but a free dyno, on a mustang dyno
    well if they give me a tune i'll sell it and offset some of the cost heh. Well car's running fine still. I'll worry about it when these things go kaput.

  14. #14
    Join Date
    Mar 2010
    Location
    Toronto, Canada
    Posts
    6,676
    Rep Points
    3,291.4
    Mentioned
    225 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Click here to enlarge Originally Posted by themyst Click here to enlarge
    well if they give me a tune i'll sell it and offset some of the cost heh. Well car's running fine still. I'll worry about it when these things go kaput.
    nothing to worry about yet, those can go like that for a WHILE

  15. #15
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by dzenno Click here to enlarge
    nothing to worry about yet, those can go like that for a WHILE
    Yeah, no worries. I'm really sensitive to when these N54's act up so if there's even a hint of something wrong I'll be sure to post again Click here to enlarge

    I don't think there's anything wrong with the turbos though. I ran a 12.4@118.9 on the Vbox, then a 12.8@118.6 with traction cutting in on both runs, pretty much 1 mph higher than Atco, so per the VBOX my car's running fine.

  16. #16
    Join Date
    Mar 2010
    Location
    Toronto, Canada
    Posts
    6,676
    Rep Points
    3,291.4
    Mentioned
    225 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    tell me about it Click here to enlarge

  17. #17
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12


    Reputation: Yes | No
    What psi are you boosting at?

  18. #18
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by Cn555ic Click here to enlarge
    What psi are you boosting at?
    I have no idea actually. On the piggybacks I never exceeded 18 psi peak, but the Cobb race map targets 20 psi in the mid range, down to 16 psi at redline.

  19. #19
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12


    Reputation: Yes | No
    Wow. That's pretty aggressive for sure. 16 at redline! Wow. Must be fast as hell!

  20. #20
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by Cn555ic Click here to enlarge
    Wow. That's pretty aggressive for sure. 16 at redline! Wow. Must be fast as hell!
    apparently not fast enough! hotrod would have me by buslengths with less boost and less bolt-ons!

  21. #21
    Join Date
    Feb 2010
    Location
    Miami
    Posts
    286
    Rep Points
    349.4
    Mentioned
    9 Post(s)
    Rep Power
    4


    Reputation: Yes | No
    upgrade those snails and get it over with!
    || DCT | ESS Tune | ACM Test-pipes | AA Green Filter | Swift Spec-R Springs | Stoptech ST-40 F || || My Youtube Channel|| My Vimeo Channel ||

  22. #22
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by yandyr Click here to enlarge
    upgrade those snails and get it over with!
    upgrading the snails aint no thang, rebuilding my tranny? That will hurt. $4k installed ftl

  23. #23
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12


    Reputation: Yes | No
    Your tranny is slipping also? $#@!

  24. #24
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10



    Reputation: Yes | No
    Click here to enlarge Originally Posted by Cn555ic Click here to enlarge
    Your tranny is slipping also? $#@!
    no tranny's fine. I'm just thinking ahead of time. If I go upgraded turbos and go boost happy the tranny will not last.

  25. #25
    Join Date
    Mar 2010
    Posts
    961
    Rep Points
    1,139.3
    Mentioned
    45 Post(s)
    Rep Power
    12


    Reputation: Yes | No
    Click here to enlarge Originally Posted by themyst Click here to enlarge
    no tranny's fine. I'm just thinking ahead of time. If I go upgraded turbos and go boost happy the tranny will not last.
    Screw the tranny! Get the stockers warranty work done and then throw some nitrous in there to the mix....It would cost you less in the long run! lol

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •