Close

Results 1 to 17 of 17
  1. #1
    Join Date
    Feb 2010
    Location
    San Antonio
    Posts
    465
    Rep Points
    278.8
    Mentioned
    0 Post(s)
    Rep Power
    3


    Yes Reputation No

    car dies coming to stop?

    not the HPF car but my wifes all OEM motor. all of a sudden it is starting to spuratically die when coming to a stop. idles ok and runs fine the rest of the time. also the smg's rev matching when shifting is out of wack.....directly related maybe?? what gives??

    idle control valve?
    MAF and/or sensor?
    Click here to enlarge
    Click here to enlarge Originally Posted by TwinturboM3
    I bang the chickens on my farm 60-130 times a day.
    Click here to enlarge

  2. #2
    Join Date
    Oct 2010
    Location
    Alberta, Canada
    Posts
    294
    Rep Points
    -1,967.5
    Mentioned
    5 Post(s)
    Rep Power
    0


    Yes Reputation No
    TPS? Dunno

  3. #3
    Join Date
    Apr 2010
    Location
    Earth
    Posts
    5,173
    Rep Points
    526.1
    Mentioned
    4 Post(s)
    Rep Power
    6


    Yes Reputation No
    Idle control valve maybe? How many miles on the car?
    Click here to enlargeClick here to enlarge

  4. #4
    Join Date
    Feb 2010
    Location
    San Antonio
    Posts
    465
    Rep Points
    278.8
    Mentioned
    0 Post(s)
    Rep Power
    3



    Yes Reputation No
    Click here to enlarge Originally Posted by GG///M3 Click here to enlarge
    Idle control valve maybe? How many miles on the car?
    somewhere around 65k
    Click here to enlarge Originally Posted by TwinturboM3
    I bang the chickens on my farm 60-130 times a day.
    Click here to enlarge

  5. #5
    Join Date
    Apr 2010
    Location
    Earth
    Posts
    5,173
    Rep Points
    526.1
    Mentioned
    4 Post(s)
    Rep Power
    6


    1 out of 1 members liked this post. Yes Reputation No
    Click here to enlarge Originally Posted by Funkboy316 Click here to enlarge
    somewhere around 65k
    I had a similar issue with my m3. Ran fine then when I came to a stop it would stall. ICV was not doing well. Replaced it never had an issue since. Some clean them and are fine as well. I would check there.
    Click here to enlargeClick here to enlarge

  6. #6
    Join Date
    Feb 2010
    Location
    San Antonio
    Posts
    465
    Rep Points
    278.8
    Mentioned
    0 Post(s)
    Rep Power
    3



    Yes Reputation No
    Click here to enlarge Originally Posted by GG///M3 Click here to enlarge
    I had a similar issue with my m3. Ran fine then when I came to a stop it would stall. ICV was not doing well. Replaced it never had an issue since. Some clean them and are fine as well. I would check there.
    i was thinking this but, but the word idle control valve was kinda throwing me because it idles fine............i owe you a pos rep. it wont let me rep you again yet.Click here to enlarge
    Click here to enlarge Originally Posted by TwinturboM3
    I bang the chickens on my farm 60-130 times a day.
    Click here to enlarge

  7. #7
    Join Date
    Apr 2010
    Location
    Earth
    Posts
    5,173
    Rep Points
    526.1
    Mentioned
    4 Post(s)
    Rep Power
    6


    0 out of 1 members liked this post. Yes Reputation No
    after many negs that happens. :-( Also another reason the reppy system is fail
    Last edited by GG///M3; 05-16-2011 at 10:02 PM.
    Click here to enlargeClick here to enlarge

  8. #8
    Join Date
    Apr 2010
    Location
    Earth
    Posts
    5,173
    Rep Points
    526.1
    Mentioned
    4 Post(s)
    Rep Power
    6


    Yes Reputation No
    Also I'm guessing this, so this is not warrantied advise. Click here to enlarge
    Click here to enlargeClick here to enlarge

  9. #9
    Join Date
    Oct 2010
    Posts
    885
    Rep Points
    8.0
    Mentioned
    1 Post(s)
    Rep Power
    0


    Yes Reputation No
    The S54 uses the throttle bodies in combination with an idle valve to idle. The ECU moves the throttle bodies to help idle, especially on SMG cars.

    Its likely a throttle body actuator issue if its messing up idling AND rev matching.

    Through an OBDII scanner on it.


  10. #10
    Join Date
    Aug 2010
    Location
    Valley Stream NY
    Posts
    3,348
    Rep Points
    2,757.4
    Mentioned
    85 Post(s)
    Rep Power
    28


    Yes Reputation No
    Ive heard of the front TPS sensor going bad as well as the gas pedal assembly..my friends car had the same issue, and we replaced the gas pedal setup with an updated part number and its been fine.

  11. #11
    Join Date
    Feb 2010
    Location
    San Antonio
    Posts
    465
    Rep Points
    278.8
    Mentioned
    0 Post(s)
    Rep Power
    3



    Yes Reputation No
    Click here to enlarge Originally Posted by 5mall5nail5 Click here to enlarge
    The S54 uses the throttle bodies in combination with an idle valve to idle. The ECU moves the throttle bodies to help idle, especially on SMG cars.

    Its likely a throttle body actuator issue if its messing up idling AND rev matching.

    Through an OBDII scanner on it.
    no codes oddly enough, and thats what's kinda weird, it does idle fine just not when stopping...lol

    what it does when i come to a stop is the RPM's are dropping to like below 500, then sometimes it will catch and surge up to normal idle RPM before stalling but more frequently its just going ahead and stalling. kinda like if i was stopping a manual car without pushing the clutch in and then pushed it in at the last second before the car stalled.
    if i just start the car in the driveway for example, the idle is solid.
    Click here to enlarge Originally Posted by TwinturboM3
    I bang the chickens on my farm 60-130 times a day.
    Click here to enlarge

  12. #12
    Join Date
    Oct 2010
    Posts
    885
    Rep Points
    8.0
    Mentioned
    1 Post(s)
    Rep Power
    0


    Yes Reputation No
    Hm I think some cars had clutch issues too - I think this might be a dealer thing, unfortunately.


  13. #13
    Join Date
    Feb 2010
    Location
    San Antonio
    Posts
    465
    Rep Points
    278.8
    Mentioned
    0 Post(s)
    Rep Power
    3



    Yes Reputation No
    Click here to enlarge Originally Posted by GG///M3 Click here to enlarge
    I had a similar issue with my m3. Ran fine then when I came to a stop it would stall. ICV was not doing well. Replaced it never had an issue since. Some clean them and are fine as well. I would check there.
    THIS! found a DIY, pulled it off today and cleaned it, that dohickey inside it thats suppose to move freely was totally seized up. sprayed it with a buttload of carb cleaner and it freed right up. gonna go ahead and pick up another one though. its only been a few hours but no more stalling and the shifts are back to normal.
    Click here to enlarge Originally Posted by TwinturboM3
    I bang the chickens on my farm 60-130 times a day.
    Click here to enlarge

  14. #14
    Join Date
    Oct 2010
    Location
    Alberta, Canada
    Posts
    294
    Rep Points
    -1,967.5
    Mentioned
    5 Post(s)
    Rep Power
    0


    Yes Reputation No
    Good to here Click here to enlarge

  15. #15
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    118,829
    Rep Points
    31,808.7
    Mentioned
    2088 Post(s)
    Rep Power
    319


    Yes Reputation No
    Click here to enlarge Originally Posted by GG///M3 Click here to enlarge
    I had a similar issue with my m3. Ran fine then when I came to a stop it would stall. ICV was not doing well. Replaced it never had an issue since. Some clean them and are fine as well. I would check there.
    This is what I'm thinking. The SMG issues might be causing it to stall since it isn't rev matching properly....

  16. #16
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    118,829
    Rep Points
    31,808.7
    Mentioned
    2088 Post(s)
    Rep Power
    319


    Yes Reputation No
    Click here to enlarge Originally Posted by Funkboy316 Click here to enlarge
    THIS! found a DIY, pulled it off today and cleaned it, that dohickey inside it thats suppose to move freely was totally seized up. sprayed it with a buttload of carb cleaner and it freed right up. gonna go ahead and pick up another one though. its only been a few hours but no more stalling and the shifts are back to normal.
    Just read this, excellent!

  17. #17
    Join Date
    Apr 2010
    Location
    Earth
    Posts
    5,173
    Rep Points
    526.1
    Mentioned
    4 Post(s)
    Rep Power
    6


    Yes Reputation No
    Click here to enlarge Originally Posted by Funkboy316 Click here to enlarge
    THIS! found a DIY, pulled it off today and cleaned it, that dohickey inside it thats suppose to move freely was totally seized up. sprayed it with a buttload of carb cleaner and it freed right up. gonna go ahead and pick up another one though. its only been a few hours but no more stalling and the shifts are back to normal.
    See I'm not here to only make shy jokes. Good to hear it was the fix. Hi 5
    Click here to enlargeClick here to enlarge

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •