What's on your mind?


[140]

Live Feed

Sticky replied to the thread Quick update - YSI at 21 psi and C16.
"
Quote Originally Posted by SexiPYm3 View Post
From what I saw, 181 was the fastest bmw.
I understand *was* considering the event is going on right now. "

Today, 05:38 PM

VargasTurboTech replied to the thread Turbo vs naturally aspirated AMG power - 2013 Renntech tuned E63 AMG M157 vs 2014 Weistec tuned SLS AMG Black Series M159.
"
Quote Originally Posted by George Smooth View Post
If I spend SLS money on a car it must lay the law in all aspects.
Truth! "

Today, 05:31 PM

SexiPYm3 replied to the thread Quick update - YSI at 21 psi and C16.
" From what I saw, 181 was the fastest bmw. "

Today, 05:26 PM

AdminTeam created the thread BDXC is now here!.
" Welcome to a real enthusiast forum BDXC. "

Today, 05:20 PM

ovitrix replied to the thread Calling all spec 3+ owners.
" The stage 2+ is more like stock. The 3+ has a harder pedal feel but not bad compared with act. That noise you have is weird. I never had that on my car after the spec combo install. Also the 3+ is very grabby compared with oem, you have to get adjusted to it. "

Today, 05:17 PM

psmith95 replied to the thread Calling all spec 3+ owners.
"
Quote Originally Posted by lamia2super View Post
idk who told it was like stock but I'm probably the one of the first to installed that clutch and its just like how you described. i had to learn and adapt to it

it has 2 position either you push it in or out and if you try to slowly lift your foot your stall every time lol

idk what that noise is btw

my flywheel rattles but it doesn't sound like that
Quote Originally Posted by lamia2super View Post
also be careful launching the car because i broke a cv joint at the track one day and had to buy another axle
"

Today, 05:16 PM

AdminTeam created the thread MNankervi is now here!.
" Welcome to a real enthusiast forum MNankervi. "

Today, 05:11 PM

Jake@Eurocharged.com replied to the thread 620 all wheel horsepower G55? Yep. Eurocharged tuned 5.7 liter built motor M113 V8 with Weistec 3.0 liter blower makes for an epic G-Wagon.
" 12.2 @114 is what i heard...waiting on slips to see if it was 12.2x or flat 12.2 "

Today, 05:08 PM

lamia2super replied to the thread Calling all spec 3+ owners.
" also be careful launching the car because i broke a cv joint at the track one day and had to buy another axle "

Today, 05:07 PM

Sticky replied to the thread Quick update - YSI at 21 psi and C16.
"
Quote Originally Posted by bobS View Post
@Sticky why didn't you go to this?
Because I didn't buy a spot and it's also Easter.

No updates that I know of anyway I'm busy. "

Today, 05:07 PM

lamia2super replied to the thread Calling all spec 3+ owners.
" idk who told it was like stock but I'm probably the one of the first to installed that clutch and its just like how you described. i had to learn and adapt to it

it has 2 position either you push it in or out and if you try to slowly lift your foot your stall every time lol

idk what that noise is btw

my flywheel rattles but it doesn't sound like that "

Today, 04:54 PM

George Smooth replied to the thread Turbo vs naturally aspirated AMG power - 2013 Renntech tuned E63 AMG M157 vs 2014 Weistec tuned SLS AMG Black Series M159.
" If I spend SLS money on a car it must lay the law in all aspects. "

Today, 04:52 PM

JonsC63AMG replied to the thread Article: Tune only W204 C63 AMG vs a bolt on Mustang GT 5.0 'Coyote' from a roll.
"
Quote Originally Posted by ChuckD05 View Post
agreed , and even better reason than... got respect for u bcu back up your claims and alwaysrematch like u did with ben and his rbs.. im actually really looking for a c63 right now , your car being a big reason why.. still no issues right? ever?
I never had issues with my c63 in the 4+yrs of ownership 33k miles now. Except for the CEL problem I had when I removed the charcoals. I think in the future I'm going to Weistec superch my C63. 130+ traps does seem nice. "

Today, 04:50 PM

psmith95 replied to the thread Calling all spec 3+ owners.
"
Quote Originally Posted by ovitrix View Post
That's how the pedal feels on a stage3+, the spec feels a lot better than act. the engagement point it is higher and it'll stay the same even after break in. Make sure you break the clutch in for 600-700 miles with lots of downshifting.
Ok good to hear it's normal.


I did notice another weird thing today though... At idle with the car out of gear I hear a squeaking sound from below, but as soon as I press on the clutch even the lightest bit it goes away. I don't even have to depress the clutch pedal I just have to tap it to the point where the dead space on the pedal is gone and you start pushing with pressure. here's a vid below. At the end I also tried to show the chatter

http://www.youtube.com/watch?v=PEJmoeNXnfM "

Today, 04:43 PM

AdminTeam created the thread NOOOOB: Jimmy35kk.
" Jimmy35kk, we appreciate you taking the time to join. "

Today, 04:30 PM

ovitrix replied to the thread Calling all spec 3+ owners.
" That's how the pedal feels on a stage3+, the spec feels a lot better than act. the engagement point it is higher and it'll stay the same even after break in. Make sure you break the clutch in for 600-700 miles with lots of downshifting. "

Today, 04:25 PM

bobS replied to the thread Quick update - YSI at 21 psi and C16.
" Any updates? @Sticky why didn't you go to this? "

Today, 04:09 PM

AdminTeam created the thread We welcome ssxrnr.
" Welcome ssxrnr, take a look around, I think you will like what you see. "

Today, 03:46 PM

BuraQ replied to the thread STFT Banks 1 & 2 - What is normal ?.
" Taking in consideration first what @stangorang "experienced" as he replaced hardware that would have had a direct affect on the problem if the hardware was faulty. However hardware was not the case. Similar experience from @SteveAZ , no matter what hardware changes were done the results were still the same.

For me I have 65K miles on my car, and the dealer replaced the injector with the newer ones when I was at 49k miles. It wasnt needed it was just something done I wouldnt have to worry about. My car does not sit, it is driven eveyday mostly highway milage

I have the orignal o2 sensors when I bought the car new. I am not cattless, I am running CP-e Highflow Catts with stock mid-catts. Mid-catts will be removed befor the end of the year. I doubt seriously a faulty o2 sensor is the issue, as my AFRs are perfectly on target

After increasing the scalar in the "cell range" where the concern is being had STFT bank 1 improved but I could not see bank 2. After logging STFT bank 2 that is where the major problem was and a significant gap between the two banks

So I raised the "cell range" of cocern in STFT bank 2 from 1.256-1.240 to 1.296-1.280 and the gap between the two banks was reduced "

Today, 03:42 PM

AdminTeam created the thread Let's point and laugh at bluesmansr.
" bluesmansr, we appreciate you taking the time to join. "

Today, 03:35 PM