• ESS-Tuning service and Alpha-N E60 M5 S85 V10 tuning issues - Third party account of switch to Evolve Alpha-N S85 tuning

      Hey guys, just wanted to share a story and do a small write up on my friends experience with his M5 over the past few months. I have been there step by step with my friend while he has modded his M5. A nice experience to me aswell as I got to see what mods did what, and how this lovely V10 responded for my future reference when I mod. My friend isn't a forum type of guy, so I'm telling his story as he urged me to share it. So let's begin the story.


      About the car:
      2010 M5 SMG 3x,000 miles
      ESS tune
      ESS SMG tune
      RPI oem catless headers with ceramic coating and wrap
      RPI oil cooler
      RPI scoops with BMC filters
      RPI GTS exhaust
      RPI pulley

      As you can see within a one year period he dropped a lot of money modding the car, also adding install prices, and maintenance like plugs, diff, tranny oil, etc. He was a true modding addict and enthusiast for this S85 beast.

      Tune wise, he started with ESS base tune only, then ESS+header tune, and finally ESS+header tune+ alpha N. Progressed nicely with the ESS tunes.
      His car worked very well through all the mods and being tune only, and FBO with header tune. The ESS tune didn't give him any issues through these mods and time that were directly related from what we could tell, power was OK, not the most consistent but OK. (really don't know how bad a tune is until you try a better tune, will get to that later)

      Where the issues startedÖ.

      What to mod next? Alpha N seemed like a good next step. So my friend got the ESS alpha N hardware and alpha N software from ESS. Installed the hardware, and uploaded the software, and this is where all hell broke loose.

      Right after flashing the car, it began throwing 02 sensor codes, all kinds of codes for both top and bottom sensors but for mostly the pre-cat 02 sensors. WTF? I was confused as hell. Put some miles on the car thinking they might go away, cleared the codes multiple times, they just instantly kept coming back. Contacted ESS, they said cant be the tune, its programmed for catless headers and alpha N.

      OK, my friend tosses out the money for new pre-cat sensors on both sides and install even though the car never had this issue before and car has under 40K milesÖ Installed new 02 sensors, No change! We try uploading the stock file, tune only file, tune+header file, etc and nothing works, car stays in limp mode and runs horrible, continues to throw 02 sensor codes. Even going back to the old header tune with alpha N uninstalled we were getting the same issue now.

      OK I checked the 02 sensors fuses for him, checked the wiring, everything checks out. How can these codes just pop up out of no where right after the alpha N software upload on a 3XK mile car? Seems like the alpha N tune from ESS did something wrong. And all the hardware retaining to the 02 sensors is perfect, double checked by a mechanic.

      So after contacting ESS numerous times for help and suggestions throughout this ordeal, they would just keep giving generic answers like, not our tunes fault, it is a hardware problem, bring it to the dealer. They went as far as to say they donít have time to troubleshoot this with him as hardware issues are time consuming for them! Go to the dealer again.

      Really I was in shock ESS didnít try to send him another tune, or adjust the tune or give him suggestions on what to try via tuning. They left him high and dry! Really lost respect after seeing what they did to him, I felt my friends pain as he loves his M5 as I do and would hate to be in this situation. It seemed 100% tuning related since the issue popped up right after flashing it with the Alpha N tune. After researching on the forums, it seems this has happened before to a member as well with ESS, where he flashed his car via ESS and the codes that were thrown keep coming up even after going back to stock tune. My friend had to no choice except to find the best indy he can and leave his car with them to try to figure out what in the world is happening even if it means reverting the car back to 100 % stock.

      Fast forward 2 weeks later, trying to fix the issue at a mechanic shop. Went as far as changing some type of CAS computer and the alternator to no fixing of the issue. Just more money dumped after this mystery ESS alpha N flash tune made the car go nuts. Car was basically just a loss!

      So now the superhero comes into play. Sal and imran @ Evolve automotive and the evolve team..

      I suggested to my friend he contact and try to get a tune from evolve since there so knowledgeable on the S85 platform and own one, and still to this day are tuning them. If anyone has most experience around the S85 ECU, how the ecu reacts and tuning them, its evolve. They would be able to solve this issue if its really tuning related.

      So with no other option then to sell the car or buy a new expensive ECU from bmw or who knows what else that would cost thousands. So he called evolve, told them his story and issues, got the evolve alpha N kit. They went above and beyond helping him, making him feel comfortable while explaining the process to him. They sent him a file to upload and then the alpha N tune upload and he loaded it up and Guess what? Not sure how he did it or what he changed but he works magic!

      NO CODES! Car was running flawless! No more limp mode, no 02 sensor codes, car was idling nice and smooth like stock. ESS idled high and rough.

      Throttle response in M mode is amazing! Just has such a great feeling putting your foot down, my friend was blown away by the drivability and response over the ESS tune.

      The midrange and top end power was down right scary. We took the car for a test drive last night so I can directly compare his old ess tunes vs this new evolve tune, and to say the least, the power was astonishing, I was so addicted! Car was just jumping and taking off like a rocket! The car was going by RPMS so much faster it was incredible! An important thing to also note was the consistency! Back to back runs, the car didn't even hiccup once, and gave the same exact hard pull each run with no variance which really shows how well a tune shines, ! My friend is just thrilled his car is in working order and now with even more power! Honestly, the ESS tune felt good, but you donít really know how good a tune is until you try a tune that is better. Then you know what the other tune was lacking, in this case, drivability, midrange/top end power, and consistency.

      I'm not biased in anyway, I don't even own a tune, but I thought this story I would share to show Evolve passion, knowledge and customer service! Not sure if ESS has to re-evaluate their tuning and alpha N tuning, but also their customer support! My friend is beyond angry with ESS as he was a very loyal, pro ESS guy and thought they were top of the line in terms of BMW tuning, and was let down immensely, and left for dead by them. I know the E60 M5 is the older platform now but customer service shouldn't be put off because of this, especially when itís a tuning issue. Anyways, it was a very expensive and tough ordeal for my friend, I tried my best to help him in diagnosing throughout this ordeal, but glad he finally got it fixed with the help of Evolve, he only regrets not going with them sooner.

      Here are some pics throughout his modding and issues:

      First test drive with the evolve tune:


      Evolve goodness






      Evolve owner happiness:


      ESS alpha N tune, high idle when fully warmed and stopped that ESS said was normal


      Vs EVOLVE stable, smooth nice idle under 1K


      Late night flashing ESS tunes to try and fix the issue after flashing ESS alpha N tune:




      RPI headers, coated and wrapped:

      BTW do not go to Autocouture in NJ to do installs on any of your cars.. There installs are very sloppy and not professional. They installed my friends headers and didn't put back the oem heat shields, the main wire of the car sat and got burned on the headers! My friend had to bring the car to another Mechanic, who had to cut away the burned wires and individually re-connect all the wires! Or replace the whole main harness of the car just because of the Autocoutures improper and sloppy/lazy work! They also do very sloppy job on car wraps! But that is another story! Find another place for car work!






      RPI oil cooler:


      Stock vs RPI pulley:


      RPI GTS exhaust:





      I know what tune i will be getting this spring now as well
      This article was originally published in forum thread: ESS tuning and service issues || EVOLVE to the resuce with more power started by 5soko View original post
      Comments 76 Comments
      1. mjmarovi's Avatar
        mjmarovi -
        Glad to hear it got straightened out. No fun to deal with idiots on your expensive car. I've pretty much learned that all the best shops are vendors on this site, and if it's something proprietory to BMW like tuning then stick to bimmerboost list of vendors.
      1. folgrz's Avatar
        folgrz -
        wow what a $#@! show. Glad your buddy finally got everything sorted out. Also I'm pretty shocked to hear about auto couture doing a shoddy job installing those parts. They seem like the know what they are doing over there and honestly this is the first that I'm hearing about them doing a bad job.
      1. 5soko's Avatar
        5soko -
        Click here to enlarge Originally Posted by mjmarovi Click here to enlarge
        Glad to hear it got straightened out. No fun to deal with idiots on your expensive car. I've pretty much learned that all the best shops are vendors on this site, and if it's something proprietory to BMW like tuning then stick to bimmerboost list of vendors.
        Thanks man! Yea, looks like bimmerboost has alot of vendors filtered and sorta out! This is nice a to have a forum members verified group of vendors with no bull$#@! attached.

        Click here to enlarge Originally Posted by folgrz Click here to enlarge
        wow what a $#@! show. Glad your buddy finally got everything sorted out. Also I'm pretty shocked to hear about auto couture doing a shoddy job installing those parts. They seem like the know what they are doing over there and honestly this is the first that I'm hearing about them doing a bad job.
        Yup, i never heard anything bad about them either, that is why i urged my sister to bring her ML63 there for a flat black wrap.. At the end, they finished the wrap , but not the first time, or second time, or third time back after there first time completion, and it was GOOD job, not an amazing and excellent job. I have never went back to them after that, and wouldn't go back to them for a wrap job or anything else.
        Alot of peeling corners and short cut corners, bubbles in some parts, badly painted pieces that were also paid to be done, i believe they did use plasi-dip. I really got angry because i recommend them, and my sisters was taking off from work, calling them to tell them that we have to bring it back for alot of small issues, and to please take care of them and take as long as needed to make sure the car is 100%, but we had to go back 3 times again after that, and really by the end of it didnt feel very warmed welcome like when we first went to ask about the job. We spent ALOT of money, about 5 grand i believe at the end of it, and was never 100% happy with the job they did, they just couldnt deliver a quality wrap and job. Like i said, id never go back to them after my experience for anything. But they tried, i guess.

        My friends experience was similar, and even after my story he wanted to give them a shot because of all the popularity on the forums.
        He spent alot of money with them, and about a grand to install the headers. They didnt put any of the OEM heat shields back on the car, and what happened was, one of the wire harnesses that runs along the side of the headers was left hanging there, and it eventually after a week or two started burning against the headers, and through the wires. The car started throwing crazy codes! All types of things were happening until the car didn't start one day and my friend had to bring the car to 3 different mechanics until 1 of them figured it out. They had to cut the harness, and re wire each wire one by one and cut out all the burnt wires!

        When my friend went back to confront them, the mechanic who did the work said he did secure the harness, but it probably came unclipped. My friend didnt believe it and was furious..
        So now, all my friends and family are non autocouture affter my experience and my friends. Also non ESS now lol.
        Here are some pics from what my friend sent me, i dont have any pics from there wrap job on my phone now.
        Anyways sorry for the thread de-rail.. Back to the main topic EVOLVE > ESS.

        Here is the wire just sitting on the header:
        Click here to enlarge

        Click here to enlarge

        Click here to enlarge
      1. bobS's Avatar
        bobS -
        I've had nothing but good experiences with the crew at ACM. They did all the work on my 335 and now everything on the m3. Sorry you had issues.

        Evolve is great, I'm glad you got everything sorted out!
      1. Sticky's Avatar
        Sticky -
        Holy crap what a detailed writeup. Ok give me a little bit to process this.

        I would have loved a dyno included though Click here to enlarge
      1. Sticky's Avatar
        Sticky -
        @5soko bad link to photobucket
      1. 5soko's Avatar
        5soko -
        Click here to enlarge Originally Posted by Sticky Click here to enlarge
        Holy crap what a detailed writeup. Ok give me a little bit to process this.

        I would have loved a dyno included though Click here to enlarge
        Yea, now that his car is working, he is trying to get a dyno in hopefully this saturday! So i will be there with video and pics if he does Click here to enlarge

        Lemme try to re upload that bad link:
        EDIT: GOT IT!

        Click here to enlarge
      1. Sticky's Avatar
        Sticky -
        Click here to enlarge Originally Posted by 5soko Click here to enlarge
        Yea, now that his car is working, he is trying to get a dyno in hopefully this saturday! So i will be there with video and pics if he does Click here to enlarge

        Lemme try to re upload that bad link:
        EDIT: GOT IT!
        Post the link here.

        I edited your post for formatting and some grammar mistakes. I left it mostly intact but changed some things to make it flow/read better as well as usage errors like there/their. I'm not going to edit it any further than that.
      1. Sticky's Avatar
        Sticky -
        It's a very writeup and account. This type of stuff is why I'm happy to have Evolve here.

        That personal touch and this types of accounts go a long way IMO. That's why even if someone is having a problem you may consider small as a tuner good customer service can generate tremendous positive reach and impact down the line.

        Some companies may be too big or making too many sales off the forums to care. This network does prefer the more one on one and hands on approach though. Most importantly it prefers positively solving car problems and people getting to enjoy their cars.
      1. 5soko's Avatar
        5soko -
        Click here to enlarge Originally Posted by Sticky Click here to enlarge
        Post the link here.

        I edited your post for formatting and some grammar mistakes. I left it mostly intact but changed some things to make it flow/read better as well as usage errors like there/their. I'm not going to edit it any further than that.
        Not a problem! I wrote it on my iphone and posted it off my phone this morning, i did read it over but quick, so thank you.

        Click here to enlarge Originally Posted by Sticky Click here to enlarge
        It's a very writeup and account. This type of stuff is why I'm happy to have Evolve here.

        That personal touch and this types of accounts go a long way IMO. That's why even if someone is having a problem you may consider small as a tuner good customer service can generate tremendous positive reach and impact down the line.

        Some companies may be too big or making too many sales off the forums to care. This network does prefer the more one on one and hands on approach though. Most importantly it prefers positively solving car problems and people getting to enjoy their cars.
        Thanks man, i wanted to share my friends story as clearly and well as i could, as i really was there for the whole process. I always like to share experiences with modding, as i know i love reading others account on bimmerboost when i see them aswell!
      1. Sticky's Avatar
        Sticky -
        Click here to enlarge Originally Posted by 5soko Click here to enlarge
        Thanks man, i wanted to share my friends story as clearly and well as i could, as i really was there for the whole process. I always like to share experiences with modding, as i know i love reading others account on bimmerboost when i see them aswell!
        It's appreciated. A lot of people are scared to post this kinds of accounts. I mean you posted what happened with supporting evidence. People should read and learn that not everything may be as it seems on forums.

        The issue is often you have a group of people who all are using the same tuner and anyone else is not with the same parts is perceived as 'inferior' somehow and it becomes us vs. them like a schoolyard group of the popular kids or something.
      1. spool twice's Avatar
        spool twice -
        I had something similar happen to my S65 tune, Sal explained why it idled at 900rpm and generated pre-O2 and vacuum codes on my particular car. It had to do something with idle speed variance not within spec, so my car ran like it was in a constant partial-cold start (like how the car runs after 30 seconds into a cold start: louder exhaust at idle, and that as aggressive VANOS cam gear ticking). I may be incorrect on the specifics, perhaps Sal can elaborate. He was able to correct it by reviewing all aspects of my file, no hesitations on his end, and doing what he does best: produce big results Click here to enlarge I can't believe ESS refused to review their file, I'm no tuning expert, but its clearly related to an incorrect setting. I don't understand why a company wouldn't go through the effort for better customer service and PR.
      1. benzy89's Avatar
        benzy89 -
        Another ESS disappointing purchase rectified but having Evolve work their magic.... Anyone else catch the Benvo retune debacle on an ESS E9x M3 s/c kit?


        Ironic that people aren't more informed with the unacceptable customer service with ESS' can tunes
      1. Sticky's Avatar
        Sticky -
        WTF would anyone have Benvo tune anything?
      1. gzim335's Avatar
        gzim335 -
        Click here to enlarge Originally Posted by spool twice Click here to enlarge
        I had something similar happen to my S65 tune, Sal explained why it idled at 900rpm and generated pre-O2 and vacuum codes on my particular car. It had to do something with idle speed variance not within spec, so my car ran like it was in a constant partial-cold start (like how the car runs after 30 seconds into a cold start: louder exhaust at idle, and that as aggressive VANOS cam gear ticking). I may be incorrect on the specifics, perhaps Sal can elaborate. He was able to correct it by reviewing all aspects of my file, no hesitations on his end, and doing what he does best: produce big results Click here to enlarge I can't believe ESS refused to review their file, I'm no tuning expert, but its clearly related to an incorrect setting. I don't understand why a company wouldn't go through the effort for better customer service and PR.
        When the m5 owner went back to sal for the burnt they told him to take a walk.ess told him were very busy and that he should take the car to bmw.
      1. gzim335's Avatar
        gzim335 -
        Click here to enlarge Originally Posted by gzim335 Click here to enlarge
        When the m5 owner went back to sal for the burnt they told him to take a walk.ess told him were very busy and that he should take the car to bmw.
        Ment sal from acm not sal from evolve.
      1. Sticky's Avatar
        Sticky -
        Click here to enlarge Originally Posted by gzim335 Click here to enlarge
        Ment sal from acm not sal from evolve.
        Why would he do that? That's just... wtf?
      1. gzim335's Avatar
        gzim335 -
        They prob knew it would cost a pretty penny to make it right.thats just my guess,the burnt smg harness caused all kinds of problems the guy replaced starter cuz the car wasnt starting at random times....the list goes on until the indy found the burned harness resting on headers.
      1. Sticky's Avatar
        Sticky -
        Click here to enlarge Originally Posted by gzim335 Click here to enlarge
        They prob knew it would cost a pretty penny to make it right.thats just my guess,the burnt smg harness caused all kinds of problems the guy replaced starter cuz the car wasnt starting at random times....the list goes on until the indy found the burned harness resting on headers.
        But they're the ones who messed it up in the first place. Why wouldn't they want to make it right?

        I guess they have so much business they don't care but if this is true everyone should know about it.
      1. gzim335's Avatar
        gzim335 -
        Click here to enlarge Originally Posted by Sticky Click here to enlarge
        But they're the ones who messed it up in the first place. Why wouldn't they want to make it right?

        I guess they have so much business they don't care but if this is true everyone should know about it.
        Acm is tristates god shop lol god forbid someone says a bad thing about them