Close

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 24 Hours Last 24 Hours Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Articles Articles
  • N54 TURBO's Avatar
    Today, 02:08 PM
    Hmm,car has been running fine for a month,now i see both where O2's connect but arent color coded.they go under intake into a harness box.you can see ontop where the adv O2's connect.
    4 replies | 121 view(s)
  • AWSAWS's Avatar
    Today, 01:01 PM
    It was about a month after I installed my GCs that a friend told me their lites had let go and done a shit load of damage. He told me that the original creator had admitted turbine blades were suffering delamination. I suspect I may well have a defective product but what the f can I do now? I run alot of water and meth so due to much lower exhaust temps my turbines would probably fail at a slower rate. I can't afford to just pay people to swap turbos on my car to take a look if they are healthy or to replace broken parts. I hope they won't fail but if they do I hope VTT will be honorable. This shit show doesn't fill anyone with confidence. I also want to say that on the single vs twin debate, I don't think 650 whp should be such a big ask for twins with sensible fueling. I stuck with twins for the quick response. Come on. Sort this crap out.
    118 replies | 12288 view(s)
  • gunda's Avatar
    Today, 01:01 PM
    I was only getting a 2c2e error and it was the extension for bank 2 that was causing the issue. You may have an issue with the connections in both banks or possibly mixed up the connectors?
    4 replies | 121 view(s)
  • subaru335i's Avatar
    118 replies | 12288 view(s)
  • Redbeanbun's Avatar
    Today, 12:41 PM
    Every table in the latest xdf for the n54 - you got the checksums covered ? the first version had checksum issues with specific tables ...
    78 replies | 7513 view(s)
  • Newguy123's Avatar
    Today, 12:21 PM
    I also forgot to mention, if you're running 18" or bigger wheels you can get their "oversized" front rotors. Takes you from oem size of 338x28mm to 350x28mm. This kit includes pads and a small bracket to move the caliper so you can fit the oversized rotors. They are the only company out there offering upgrades like this for us 1er's. That option is still 3-4lbs lighter per corner then oem :) http://www.racingbrake.com/Two-piece-rotor-Open-Slot-135i-Over-sized-Big-p/2232-k.htm
    5 replies | 463 view(s)
  • N54 TURBO's Avatar
    Today, 12:09 PM
    ill check my connections.can one bad connection on either banks cause both a 2c2e & 2c2d codes?
    4 replies | 121 view(s)
  • Newguy123's Avatar
    Today, 11:54 AM
    Yup. You get the whole set front and rear for around $1400 with pads shipped using the gs-10 code. you can buy front BBK used for around 2k. I know it's not the cheapest option for a lot of people out there but it's a great in between. These things can take some serious abuse :)
    5 replies | 463 view(s)
  • Newguy123's Avatar
    Today, 11:50 AM
    Not really, the only other OEM size lightweight 2 PC replacement option are the ECS ones at $500 for JUST rotors no pads. So actually very comparable in price to the other option. The ECS ones ONLY come in drilled/slotted, weigh 1.3lbs more PER side and cannot be rebuilt. They aren't cheap but they aren't overpriced either.
    5 replies | 463 view(s)
  • Traf's Avatar
    Today, 11:16 AM
    Too bad there is no single in Europe :(
    11 replies | 1066 view(s)
  • mike@n54tuning.com's Avatar
    Today, 10:57 AM
    Bump for a great deal @ www.n54tuning.com Lowest Prices on the FORUMS!! Mike
    6 replies | 1573 view(s)
  • mike@n54tuning.com's Avatar
    Today, 10:57 AM
    Bump for a great deal @ www.n54tuning.com Lowest Prices on the FORUMS!! Mike
    37 replies | 10369 view(s)
  • mike@n54tuning.com's Avatar
    Today, 10:56 AM
    Bump for a great deal @ www.n54tuning.com Lowest Prices on the FORUMS!! Mike
    174 replies | 34851 view(s)
  • gunda's Avatar
    Today, 10:32 AM
    I had the same issue, it ended up being a wiring harness extension i made that caused the 2c2e issue. http://www.n54tech.com/forums/showthread.php?t=47241
    4 replies | 121 view(s)
  • AdminTeam's Avatar
    Today, 10:32 AM
    Harbeans, we appreciate you taking the time to join.
    0 replies | 67 view(s)
  • Torgus's Avatar
    Today, 10:31 AM
    The only reviews I can find online are not very positive. Given the known issues the GCs have and the failure rate it seems par for the course for zage. Seems like the future of the platform is cheap(quality and price) Chinese twins or American made single turbo kits. A cast single turbo kit would sell well I bet if it was priced appropriately. I'm surprised no one has made a kit around the cast spa single turbo manifold.
    11 replies | 1066 view(s)
  • Torgus's Avatar
    Today, 10:14 AM
    Probably getting close to 1/3 or 1/2 the cost of a used bbk. Glad you like them.
    5 replies | 463 view(s)
  • N54 TURBO's Avatar
    Today, 09:52 AM
    in running a top mount VM single turbo kit about a month with adv02 sensors,jb4 and mhd with adv box checked.yesterday noticed was running lean pegged at 20 on jb4 log.tried searching but not clear on fix.could this be a adv sensor issue?something else?
    4 replies | 121 view(s)
  • Traf's Avatar
    Today, 07:26 AM
    Way too expensive for what it is man
    5 replies | 463 view(s)
  • titium's Avatar
    Today, 02:09 AM
    Same here...
    118 replies | 12288 view(s)
  • mave198's Avatar
    Today, 02:02 AM
    Well, this thread has convinced me to go single when I upgrade next year...... Thanks guys!!
    118 replies | 12288 view(s)
  • Newguy123's Avatar
    Today, 01:57 AM
    Hey guys I decided to pull the trigger on some 2 peice light weight rotors and pads from racing brake. To give you some background I do a lot of 1/2 mile racing and have warped multiple sets of rotors and cracked pads from the high speed stops. Wanted to give some initial testing feedback on the RB OE replacement rotors and high temp XT910 street pads. I did a few consecutive 130mph down to about 40mph hard stops back to back after I bead them in. On the stock 135i rotors this would have warped the rotors and cracked the pads. The RB rotors and pads took it like a champ! No pedal fade no vibrations just a crisp bite at the pedal as I expected. These rotors performed flawlessly through my stress tests and I am confident they will not warp after the next 1/2 mile event.Since the high speed stops I have done 3 separate canyon runs with the new setup, they have performed flawlessly with no squeak and much less brake dust over the oem stuff. the pedal feel is different then stock, you really have to push harder on the pedal when coming in hot which is a little weird to get used to cus the stock pads bite so hard with such little input.... Prob why they warp so easy ha! These rotors are 2 peice so when it's time for replacement you can order the rotor rings by them selves and re use the aluminum hat to cut down on replacement costs. Also these rotors shave 10-12 lbs of rotational weight in the front and another 10lbs if you choose to buy the rears also. To me that is worth it in itself. I purchased a front set first cus I didn't see a ton of independent reviews on the full kit. After about a week with the front rotors and pads I knew I had to have the rears. The look and unsprung weight savings alone is well worth the cost in my book. The front pads retain the OEM brake sensor while the rear pads do not. As far as I know Racing Brake is the ONLY company out there that makes a 2 PC light weight OE replaceable rear rotor for the 135i. You can really feel the difference with these things on all 4 corners! the car feels really light on its feet and feels like it turns in quicker. If you purchase the front and rear rotors/pads together you save also to save some additional money at check out use code GS-10. :music-rockout: Here are some pictures....
    5 replies | 463 view(s)
  • AdminTeam's Avatar
    Today, 01:24 AM
    by.skif, we appreciate you taking the time to join.
    0 replies | 154 view(s)
  • levanime's Avatar
    Today, 12:32 AM
    little update, I left screen on writing error and inpa cable started lighing as for activity maybe its flashing it in background?
    19 replies | 1368 view(s)
  • levanime's Avatar
    Today, 12:29 AM
    Can I also ask whats solution for this? I was playing with it on the bench, testing version 2 with inpa cable i've read dme fine (its IJE0S) when tried to write first it gave authentication error then it gave other error now its stuck in recovery mode I have many other tools to recover this DME, was just curious, maybe I could help with finding bug
    19 replies | 1368 view(s)
  • SFvalley335i's Avatar
    Yesterday, 11:56 PM
    The manufacturer zage wont sell the GC turbos to anyone in the US. If you're in Canada or else where you can purchase directly from mfg for $1900. Read about zage online, reviews weren't that good.
    11 replies | 1066 view(s)
More Activity